Support » Plugin: LiteSpeed Cache » How can I disable homepage from being cached

  • Resolved diraph

    (@diraph)


    I have a news blog and the homepage is usually updated regularly. I don’t want the homepage to be cached. How will I do that? Please help.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    If your front page has wp-admin , then

    if not , add /$ to do not cache URI

    Best regards,

    Thread Starter diraph

    (@diraph)

    Thanks. Its done

    Thread Starter diraph

    (@diraph)

    Hi again. I used the first option but it didn’t work. The homepage is still cached.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    No , it’s not cached by LiteSpeed, but that cache-control header, that header tells browser to cache the page , you need to get rid of it

    Best regards,

    Thread Starter diraph

    (@diraph)

    Thanks for your help. Any way to remove that?
    I use Cloudflare, could that be the problem?

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    I don’t know where you added , but check .htaccess

    No , I don’t see Cloudflare in use , from the http header.

    Best regards,

    Thread Starter diraph

    (@diraph)

    Okay Thanks. I will look into that

    Thread Starter diraph

    (@diraph)

    Hi, I know I am probably asking much, please I checked the .htaccess file and I didn’t see any cache-control header
    Any other place I can check??

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    I honestly don’t know , you need to contact your hosting provider on this

    if it’s your own server you are managing it , try use grep to do a text search over your site files

    Best regards,

    Thread Starter diraph

    (@diraph)

    Oh. I contacted the his and they claim to have fixed it. Can please help me check?

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    No , that cache control header is still there.

    Thread Starter diraph

    (@diraph)

    Thanks alot for replying. I contacted my host again and they said they have removed it now.

    I know this might be inconvenience for you but could you please help me confirm or tell me how to check it myself.

    Hoping to hear from you soon.

    Plugin Support qtwrk

    (@qtwrk)

    cache-control: public, max-age=7776000

    still seeing it

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘How can I disable homepage from being cached’ is closed to new replies.