Support » Theme: Stork » How can I disable external font styles from googleapi

Viewing 8 replies - 1 through 8 (of 8 total)
  • Theme Author justgoodthemes

    (@justgoodthemes)

    Hi there,

    since you’re not using a child theme to modify Stork, open the functions.php file and remove the following code on line 95:

    wp_enqueue_style( 'jgtstork-fonts', jgtstork_font_url(), array(), null );

    Then edit the style.css file of the theme and remove ‘Source Sans Pro’ font in the font-family declaration on line 149:

    html,
    button,
    input,
    select,
    textarea {
    	font-family: 'Source Sans Pro', 'Helvetica Neue', Helvetica, sans-serif;
    }

    Also, if you want, you can remove Google font loading in the theme editor as well. For this open functions.php and change the code on line 19 to this:

    add_editor_style( array( 'css/editor-style.css' ) );

    Then edit the css/editor-style.css file of the theme and remove ‘Source Sans Pro’ font in the font-family declaration on lines 13 and 244.

    Hope this helps.

    Asta

    Thank you for your answer. Your solutions changed the font of my website. (OK)

    But I still see these codes on my HTML;

    <link rel=’stylesheet’ id=’open-sans-css’ href=’//fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&subset=latin%2Clatin-ext&ver=4.1.1′ type=’text/css’ media=’all’ />

    Theme Author justgoodthemes

    (@justgoodthemes)

    Hi,

    we do not use Open Sans font in Stork theme. Maybe some plugin adds this font? Can you give me a link to your site?

    Asta

    Theme Author justgoodthemes

    (@justgoodthemes)

    Are you viewing your site when you’re logged in WordPress admin panel and the toolbar is enabled? If so, then WordPress admin panel loads Open Sans font and that’s why you see it.

    Yes, you are right.

    I logged out, but I still see it on my HTML codes.

    I am using W3 total cache and htaccess caching. I cleared w3tc caches and my browser cache. but, they are still there. I will wait for a while (en of the expires of caches)

    I checked it via http://tools.pingdom.com/fpt/#!/b3fdi0/www.hristiyan.net It is still there.

    Theme Author justgoodthemes

    (@justgoodthemes)

    I checked the link you gave above and there’s no Open Sans there. So probably you’re talking about the Source Sans Pro font. Have you removed the code using the instructions I gave you before? If you’re uncomfortable to edit PHP files, you can send me your functions.php file via justgoodthemes [at] gmail.com and I will check it.

    It worked! Thanks for your support!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘How can I disable external font styles from googleapi’ is closed to new replies.