Support » Fixing WordPress » How auto hyperlink in comments?

Viewing 14 replies - 1 through 14 (of 14 total)
  • That should be “on” by default in any WP installation.

    How can I modify my comments form so that there’s no “Website” box on the comments page? Is there a special option to turn this off? If not, where can I insert a rel=”nofollow” tag?

    @shawnwasson
    Use normal html for hyperlinks and images.

    @netdetective
    Write a plugin to filter the comment.

    Netdetective: please start a new topic next time….

    In order to do away with the “website” entry field, open the comments.php file for your theme, search for the following code and delete ONLY this code:

    <p><input type="text" name="url" id="url" value="<?php echo $comment_author_url; ?>" size="22" tabindex="3" />
    <label for="url"><small>Website</small></label></p>

    I could also comment it out with # or <-! in case I later decide to restore it.

    Is it ever recommended to disable the “website” box? Do posters ever have a problem with that?

    Yes, you could certainly comment it out instead; I don’t bother to post that most of the time because then you get the “how do I do that?” question from people….

    I wouldn’t know whether posters have a problem with it; it’s not required after all, and personally I never use it when I do post somewhere. If I want the world to have my site addys I’ll handle it on my own.

    Commenting it out with <!– works.

    If my goal is to prevent comment spam and not give away free pagerank to spammers, disabling “Websites” is only half the battle, since by default WP automatically converts URLs into active links.

    It would be so much easier if we would check the facts before talking 🙂
    The links in comments will have the rel='no-follow' which means no “free pagerank”. Just check out the source of a single post with comments that have URLs.
    And the commenter’s website-link also has the “no-follow”.

    I wish I could say that helped. My website is:
    http://www.bareknucklepolitics.com and if you check out any of the comments a web address will not show up as a hyperlink.

    Try to switch to another theme. If the links work in the comments – it is a theme related issue.

    Damn….

    Is it possible to turn off automatic hyperlinking of URLs in the body of the comments, or have rel=”nofollow” automatically added to any hyperlinks?

    Netdetective,
    do you read the replies or you just post?

    I think I have it figured out. Sorry for the confusion.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘How auto hyperlink in comments?’ is closed to new replies.