Support » Plugin: Document Gallery » HOT: Search Not Working. Help!

  • We’ve uploaded a lot of documents into several categories. We’re displaying different category’s documents on different pages through the shortcodes.

    For example, we’re displaying HR forms via:
    [dg order="ASC" orderby="title" id=-1 category="human-resources" new_window="true"]

    The documents display on the page fine. However, when you try to use our site’s search bar, it doesn’t find any of the documents. How do make all documents pull into search results?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Dan Rossiter

    (@danrossiter)

    Hi christianmyrick,

    If I understand your question correctly, this is expected behavior. Standard WordPress search does not expand shortcodes (including [dg]) when finding matches. I was able to find SearchWP which seems to implement what you are looking for (for a price). I was not able to find any free solutions.

    -Dan

    I have an intranet with tons of PDFs, Document Galley, Enhanced Media Library and Relevanssi Search plugin – all free.

    With Enhanced Media Library (or any similar tool) its possible to categorise media uploads.

    With Relevanssi to choose which categories to include in search.

    Works perfectly. But note that the media itself is shown in the search results, not the page on which it is listed.

    My theme can optionally show the category of the media. I use the Redirection to redirect to relevant page if user should choose to click on it. That’s doable cause I’ve only got a handful of categories.

    Kind regards
    Bjarne

    Hi Bjarne,

    Thank you for your input. Can you confirm any specific configurations or settings you had to put into place? We use Document Gallery and Enhanced Media Library. We have a lot of different categories.

    At this point, I just need a document to be displayed in search results if any of its title is searched.

    Thanks,
    Christian

    Bjarne,

    Any idea how to update the media link? I’m able to see the document in search results; however, its link is incorrect. It removes “/wp-content/uploads/” from the url structure and treats the media link as if it’s a post or page without a parent.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘HOT: Search Not Working. Help!’ is closed to new replies.