Support » Plugin: Wordfence Security - Firewall & Malware Scan » Hostgator TOS CPU Abuse

  • Resolved jeffreyd000

    (@jeffreyd000)


    Hostgator has started shutting down my sites one by one due to CPU overhead being caused by Wordfence. I’ve been running WF for over a year and this just started happening seemingly after the most recent update.

    Your account has been abusing CPU resources for an extended period of time and has been disabled in order to ensure continued performance stability of the account and server. While we do limit each account to no more than 25% of a system’s CPU in our terms of service, we do not actively disable accounts until they greatly exceed that number, which is what happened in this case.

    CPU Seconds used in the past hour: 2501.09, 70% CPU
    Wed Sep 16 23:01:31 CDT 2015
    Running Processes:
    username 18923 57.8 0.5 384496 90788 ? SN 23:01 0:17 /opt/php53/bin/php-cgi /home/username/public_html/wp-admin/admin-ajax.php
    username 19228 86.7 0.5 372076 88084 ? RN 23:01 0:08 /opt/php53/bin/php-cgi /home/username/public_html/wp-admin/admin-ajax.php

    Current Site Requests:
    50.87.—.— mydomain.com /wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=1&c
    50.87.—.— mydomain.com /wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=1&c
    50.87.—.— mydomain.com /wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=1&c
    50.87.—.— mydomain.com /wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=1&c
    50.87.—.— mydomain.com /wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=1&c
    50.87.—.— mydomain.com /wp-admin/admin-ajax.php?action=wordfence_testAjax

    Reference: ui
    CPU Usage: 151.2% (warning)

    https://wordpress.org/plugins/wordfence/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WFMattR

    (@wfmattr)

    It may be that the host just changed what they consider to be an acceptable limit — I don’t think the latest Wordfence updates would have any significant effect on CPU usage.

    Still, they mentioned using 2501 CPU seconds in an hour, which is quite a lot for most single sites. Can you list which options you have enabled under the “Scans to Include” section of the Wordfence options?

    If you have “Scan image files as if they were executable” or “Enable HIGH SENSITIVITY scanning” enabled, those can make the scans take a lot longer — we normally recommend leaving those disabled unless cleaning up a suspected hack.

    Also, if you ever leave a browser window open on a Wordfence page, it will request updates from the server every couple of seconds. You can either close your browser or go to a different page — or increase the option “Update interval in seconds” so the browser won’t request data as often.

    jeffreyd000

    (@jeffreyd000)

    Thanks for your response. Under scans I had everything checked except High Sensitivity and checking themes against the repository.

    What might you suggest would be the least amount of things I could get away with and still feel comfortable?

    Plugin Author WFMattR

    (@wfmattr)

    If you have a lot of images, or large images, or large backup files, then disabling “Scan image files as if they were executable” may make a big difference.

    You can usually also disable “Scan files outside your WordPress installation”, but that may not make much of a difference if you don’t have other non-WordPress folders (like non-WordPress forum software or something).

    If you look at the Scan page after the next scheduled scan runs, you can see the start and end time of the last scan that has run, to see how much of a difference these have made.

    Most of the others, I’d hesitate to disable, if the scan time drops enough. If necessary, you could disable the comment scan, which may help if you get a lot of comments. (If you have a ton of comments marked as spam, deleting them may help to, as they wouldn’t need to be scanned anymore.)

    Make sure also near the bottom of the Options page that “Enable debugging mode” is not enabled — if you ever turned it on to check something, it can make your scans take longer if it was left on.

    jeffreyd000

    (@jeffreyd000)

    Thanks very much for all of your helpful suggestions. Lots of images, yes. I’m also going to move away from Hostgator as they have been horrific and get a managed VPS for my clients.

    It sounds more like an EIG problem than a WF problem. 🙂

    That said, Matt’s suggestions were helpful and educational. Appreciate how WF supports and grows.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Hostgator TOS CPU Abuse’ is closed to new replies.