Support » Plugin: Global Gateway e4 | Payeezy Gateway | » Hosted Checkout Error – Demo/test payment page not working anymore.

  • Resolved sslaughter

    (@sslaughter)


    I posted this in a new forum top on developer.payeezy.com, but I’m not sure which that is review more often than the wordpress support site, so I am posting it here as well.

    I’ve been working with a Test Payment page set up on demo.globalgatewaye4.firstdata.com and since Monday when ever I try to process a form through it I am given the “Hosted Checkout uses security mechanisms…” error page instead of being allowed to enter CC information.

    I’m running off of WordPress 4.5.1 and “Global Gateway e4 | Payeezy Gateway” plugin version 2.0

    • I’ve deactivated and removed the plugin.
    • Installed the plugin through the word press site
    • Clicked on the Payeezy link on the dashboard and filled in values for “Payment Page ID” and “Transaction Key”
    • Those values I got from a Test payment page set up on https://demo.globalgatewaye4.firstdata.com/payment_pages
    • I choose a few fields in the plugin (firstname/lastname, PO Number, Invoice Number) then clicked “Generate Code”
    • To test the form I clicked “Current HTML”, filled in some values for a $1 amount and then clicked submit
    • I get the wait graphic and then I am sent to the “”Hosted Checkout …” error page

    This has been happening for the last 2 days – every since Monday. I may have updated to version 2 Monday, but I am not sure. One weird thing I noticed. I could swear that the “Current HTML” code at one time contained a hidden field called “token”, but I do not see that anymore.

    Note: This same Test payment page was working for me last week.

    https://wordpress.org/plugins/globe-gateway-e4/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter sslaughter

    (@sslaughter)

    So – any one else experiencing this problem ? Any ideas on what is going on ?

    Thread Starter sslaughter

    (@sslaughter)

    I found out what was going wrong. By default. after installing the plugin the “Auto Submit Payment” value is set to “Live”. After changing it to “Demo” things started processing correctly.

    Just wish the error message had been a little easier to figure out.

    Plugin Author DonnellC

    (@donnellc)

    Good Afternoon sslaughter,

    I’ve removed the hidden field called “Token” that contained PHP for the time being. Tokens will be added back in to the plug-in for added security.

    The “Auto Submit Payment” will always be default.

    Have you tried the new backup button?

    Thread Starter sslaughter

    (@sslaughter)

    Thanks, I got it resolved though.

    My issue ended up being that by default the setting is “Live” instead of “Demo” when you initially install the plugin. It looked like it was a value for “Auto Submit Payment” because of the way the values are laid out in the settings page

    x Auto Submit Payment
    Live or Demo : Demo

    But it was just the “Live or Demo” value.

    === Ignore the below if you want, it falls under “feature” request ======

    One thing it would be nice of you to work on is to make a separate “Save” button for the “Payment Page ID” and “Transaction Key” values. Right now there is just the “Generate HTML” button, which saves those values – and then stomps on the previous HTML Form value.

    We have customized the HTML Form a little bit, so when I have to change the Payment Page ID from its DEMO value to its real value, I have to remember to first copy the HTML, and then edit to put it back in place. I’m pretty sure that sometime soon, someone else not knowing about this will go to change the “Payment Page ID”, and wipe out the form.

    Also – to make the form code a “little” more portable – instead of hard-coding the plugin path for the confirm.php file in the forms “action=” tag you could use plugin_dir_url

    <form method=’POST’ action='<?php echo plugin_dir_url( __FILE__ ) ?>confirm.php’>

    This makes it a little more portable for those who modify their forms and who want to move it from test servers to production servers

    (Our issue is compounded by the fact that we have Developer, Test, and PRO servers, so that is 2 deploys, each requiring some human intervention and setup)

    DonnellC,
    Our plugin worked fine for 3 months then suddenly stopped. After form submission, we receive an error on the resulting page on globalgatewaye4.firstdata.com that indicates “globalgatewaye4.firstdata.com”. The email we received says:

    The following errors were found:

    * x_amount : can only contain digits, a comma and a decimal point.
    * x_merchant_email : Invalid email format. Must be username@domain

    Any idea what changed?
    here’s our form: http://www.metroparks.org/make-a-difference/gifts/donate/online-contribution-form/

    The parameters of the request are

    – 30 –

    Plugin Author DonnellC

    (@donnellc)

    Powerskirt,

    The gateway has updated the way they process email address.
    At this time you can only have 1 merchant email address in the field.
    With the new update, you can no longer have 2 or 3+ email address for the gateway to send notices.
    For example:
    email1@test.com, email2@test.com, email3@test.com,
    or
    email1@test.com; email2@test.com; email3@test.com;
    The need 1 email address.

    I called the gateway to find out why they made the change. They didn’t have an answer.
    By correcting the email will fix your error.

    To make the change. Please go to edit plugin.
    Select Global Gateway e4 | Payeezy Gateway | Clover Gateway and press “Select”
    Next On the right hand side, click on the file that says”xlogin_transkey.php”
    update the “$x_merchant_email”
    from
    $x_merchant_email = “email1@test.com, email2@test.com, email3@test.com”;
    to
    $x_merchant_email = “email1@test.com”;
    Go down to the bottom of the page and click on “Save”

    Please let me know if this helps.

    Fantastic – that was exactly the issue. We took out the extra emails and now the form is working fine. Thanks for your speedy reply.

    Our form has stopped working again. We are getting a “Unable to proceed with payment
    We cannot proceed with payment because of technical difficulties.” message. Any idea if something changed again on the First Data end?

    https://globalgatewaye4.firstdata.com/collect_payment_data?ant=199b5671321db016f7cf93a9f079ca8c&merchant=WSP-FIVE-Wp%40JNABF4Q&order=85909760b2051cb746200516dfce980ee633d134adf739003e5630da1a6a98c8&t=1

    Plugin Author DonnellC

    (@donnellc)

    Did you recently update the plugin?

    If so. You will need to re-setup the plugin.
    Please email me at support@djkidnyce.com to take a look at your site.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Hosted Checkout Error – Demo/test payment page not working anymore.’ is closed to new replies.