Support » Installing WordPress » Host Upgraded 12-26 to php 4.3.10: WP not compatible?

  • 123ehost.com (support@123ehost.com) says to me when blog failed Sunday morning: “Yesterday, we had an urgent upgrade to php. There was a security hole in php 4.3.9 and it was upgraded to 4.3.10. Contact the author of your script for a updated version, in order to work with php 4.3.10.

    No user names or db names or passwords have changed whatsoever. I’ve put up a temp index.html to tell bloggers it’s “out of order” right now. GRRRR
    I have backed up everything including database. Re-uploaded new WP files but cannot “install” to get new SQL compatible tables, etc., as per running in I.E. browser dialogue in install.php says: “You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.” Help!
    Error message returned when you surf to blog is:
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,]
    SELECT DISTINCT ID, category_id, cat_name, category_nicename, category_description, category_parent FROM wp_categories, wp_post2cat, wp_posts WHERE category_id = cat_ID AND post_id = ID AND post_id IN (,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,)
    Warning: Invalid argument supplied for foreach() in /home/whyjohn/public_html/blog/wp-blog-header.php on line 478
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,]
    SELECT ID, COUNT( comment_ID ) AS ccount FROM wp_posts LEFT JOIN wp_comments ON ( comment_post_ID = ID AND comment_approved = ‘1’) WHERE post_status = ‘publish’ AND ID IN (,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,) GROUP BY ID
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,]
    SELECT post_id,meta_key,meta_value FROM wp_postmeta WHERE post_id IN(,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,) ORDER BY post_id,meta_key
    Fatal error: Call to undefined function: array() in /home/whyjohn/public_html/blog/wp-includes/functions.php on line 1129

Viewing 7 replies - 1 through 7 (of 7 total)
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Host Upgraded 12-26 to php 4.3.10: WP not compatible?’ is closed to new replies.