WordPress.org

Support

Support » How-To and Troubleshooting » Host Ran Upgrade, Lost Everything

Host Ran Upgrade, Lost Everything

  • willfulexpose
    Member

    @willfulexpose

    Now I’m trying to restore from a backup I made in phpmyadmin. It’s a month old, but at least I have that. I’ve read the documentation at the Codex, but it’s not working for me.
    I have a backup file called localhost.sql that I made with other instructions from the codex. When I follow the restore instructions, I get the error message “The document contains no data.”
    This happens regardless of whether I try to use the text or zipped sql files and regardless of which compression option I select.
    Any ideas for what I can do to get this fixed?

    My site is willfulexpose.com.

Viewing 15 replies - 1 through 15 (of 18 total)
  • willfulexpose
    Member

    @willfulexpose

    Oh yes, and let me add that there is definitely data in the backup. It’s around 1,500 KB. Not too large, not too small.

    You are not at Web Mania are you ?

    willfulexpose
    Member

    @willfulexpose

    No, Infinityhost.

    Don’t worry I think Root’s growing pains of paranoia after a bad experience:)

    I would contact your host to see if they have another copy of the backup in case your copy is off.

    Failing that, have you read this:

    http://www.tamba2.org.uk/wordpress/backup/

    I don’t know if the codex is the same, but that’s generally a good guide on how to back and restore successfully.

    Not sure if that’s much help. It’s possible that the db was not correctly backedup?

    James Huff
    Support Team Rep.

    @macmanx

    Have you contacted your hosting provider?

    willfulexpose
    Member

    @willfulexpose

    Jinsan:
    Thanks, but I tried that documentation as well. It didn’t work either. I’ll keep trying though.

    macmanx:
    I have tried, but they are not responding to any of my help tickets. I will call in a minute.

    EDIT: Called, but phone support has ended for today.

    Does the content of the backup file look normal?
    Just try to copy the whole content of the file and run it as a sql query in phpmyadmin.

    willfulexpose
    Member

    @willfulexpose

    I don’t know what normal is. Here’s an excerpt:
    # phpMyAdmin SQL Dump
    # version 2.5.4
    # http://www.phpmyadmin.net
    #
    # Host: localhost
    # Generation Time: Mar 31, 2005 at 03:56 PM
    # Server version: 3.23.56
    # PHP Version: 4.1.2
    #
    # Database : <code>DB

    #
    CREATE DATABASE DB;
    USE DB;

    # ——————————————————–

    #
    # Table structure for table blacklist
    #

    DROP TABLE IF EXISTS blacklist;
    CREATE TABLE blacklist (
    id int(11) NOT NULL auto_increment,
    regex text NOT NULL,
    regex_type enum(‘ip’,’url’,’rbl’,’option’,’auto-url’,’auto-ip’,’regex-url’,’regex-ip’) NOT NULL default ‘url’,
    PRIMARY KEY (id),
    KEY id (id),
    FULLTEXT KEY regex (regex)
    ) TYPE=MyISAM AUTO_INCREMENT=2449 ;

    #
    # Dumping data for table blacklist
    #

    Do you think copying that as a sql query would work?
    Thanks so much for helping me!

    Oh no…just had a thought. The backup is in 4.1.2 PHP, and now I have 4.3.2 PHP! Could that explain why it’s not working?

    willfulexpose
    Member

    @willfulexpose

    I had a conversation with one technician. She said thet guy who transferred the files should have a backup of the database. I can pray. I’ll know by tomorrrow. Not very fast service, eh?

    Mark (podz)
    Support Maven

    @podz

    The above file looks fine.
    If you get no joy, I’ll have a go at it for you – drop me an email ( tamba2 at gmail dot com ) and we’ll go from there.

    RosieMBanks
    Member

    @rosiembanks

    Maybe this will help? Podz saved my very small database in this thread.

    wilfulexpose

    It looks like you have much of your site back up. If you are still attempting to import post content, then you do NOT need to run that SQL query as it exists. It will erase and re-create your database losing more recent entries. If you start with the line “# Dumping data for table blacklist” then you will only import posts. This assumes that your database is set up and the table ‘blacklist’ exists. Email me if you have any questions:

    glenn @ thedixons.net

    willfulexpose
    Member

    @willfulexpose

    Thanks everyone. I got a lot of things imported via my host, but some new problems have come up. When he/she/it restored comments, something went terribly wrong with the database. (I should note that this problem is only occuring on my main blog. It got new comments before the old comments were reinstored, whereas the other blog didn’t. I think that is what caused the problem.)
    Basically, whever I do anything involving comments and mysql, I get an error message. Most notably, even when I directly enter something like UPDATE wpWE_comments SET comment_content = 'You should have as much fun as humanly possible while over in Europe. Be a problem child, for sure! Just don’t end up in jail. :) ', comment_author = 'Johnnie Walker', comment_author_email = '', comment_approved = '0', comment_author_url = 'http://www.niteowl.tv/' WHERE comment_ID = 2179 into the mysql query window, I get an error message like this:

    MySQL said:
    #2013 – Lost connection to MySQL server during query

    What in the world can be done about that?

    Mark (podz)
    Support Maven

    @podz

    You should be able to empty the table that was being imported and try again. That does not sound great though and if that error repeated I’d be having words with the host.

    willfulexpose
    Member

    @willfulexpose

    Podz, I will try what you have suggested if a few other plans I have don’t work. Actually, I don’t have those plans yet: A couple of friends are looking at my databases and specific errors. Hopefully they’ll find something without deleting the table (which I’m avoiding because I would loose 7 days of data).

    Once/if I find the solution, I will definitely post it. This is a pretty specific problem, but maybe someone else will have it eventually. Oh yes, and I will definitely be having words with my host.

    Thanks for your help.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Host Ran Upgrade, Lost Everything’ is closed to new replies.