Support » Plugin: FG Magento to WooCommerce » Horrible experience

  • We paid for the premium version and it’s been nothing short of a nightmare.

    The plugin doesn’t work well at all.

    – Locks up our server even after following all instructions and increasing all limits on a large powerful server
    – Import gets stuck
    – Import % complete is completely useless along with the logs
    – Support hasn’t helped at all after reaching out multiple times they just give the run around

    STAY AWAY!

Viewing 4 replies - 1 through 4 (of 4 total)
  • may I ask what you ran into
    Could you bullet list the issues you had?
    Or have you completely moved on now?

    I’ve experienced the same stalling you’re seeing with the plugin (both free and premium versions), as well as the % bar going well over 100% by the time it finishes. I’ve run through a migration three times and each time had to resume it at least 20-30 times for it to finally finish.

    This is a major pain, no doubt about it, but I’ve not noticed any duplication of records and the plugin seem to bring over everything it says it will. I, too, reached out to the plugin author and didn’t get much help about the issue – but he was responsive at least. What I did was run the import and tail the progress log directly since the UI log window doesn’t update:

    tail -F wp-content/uploads/fgm2wcp-progress.json

    I essentially waited at least 5 minutes before figuring the process stalled, then I reloaded the plugin page and resumed again. Rinse/lather/repeat… for as long as it takes for the plugin to complete the migration. It seems to progress about 5% each time, at least for the migration I did.

    If I had lots of time on my hands, I’d put a lot more logging in place so there’s a sense for where the plugin just gives up, times out, or whatever. It’s gotta be something that can be mitigated in some way.

    For all its failings, this plugin did save us hundreds of hours of work manually copying almost 500 products from old site to new. I looked at other plugins but they don’t seem to have anywhere near the breadth this one does. I just hope it can be strengthened in the weeks/months to come, so it can literally be a one/few-click progress, not 20-30 times that.

    I’ll add, too, that we were only able to get the PHP limits increased by adding directives to the .htaccess file. wp-config.php and even php.ini didn’t seem to honor those settings. This is what we added to .htaccess:

    php_value upload_max_filesize 256M
    php_value post_max_size 512M
    php_value max_execution_time 300
    php_value max_input_time 300
    php_value memory_limit 256M
    

    Hope this helps.
    -e

    • This reply was modified 9 months, 4 weeks ago by BertPC.
    Plugin Author Kerfred

    (@kerfred)

    I’m sorry about your issues.
    Generally, if the import gets stuck, it comes from a timeout or a memory full on the server.
    If you can change the php.ini file, you can increase these values:

    max_execution_time=3600
    max_input_time=3600
    memory_limit=1G
    post_max_size=1G
    upload_max_filesize=2G

    If you are on a shared host, you can’t modify the php.ini file. Another solution is to install WordPress on your local computer and run the import in local. In this case, you won’t have the limitations of the shared host. Here is the procedure:
    on Windows: https://www.fredericgilles.net/migrate-wordpress-local-windows-server/
    or on Mac: https://www.fredericgilles.net/how-to-migrate-to-wordpress-from-various-cms-on-a-mac-local-server/

    In any case, if you click again on the import button, it will resume the import where it left off.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Horrible experience’ is closed to new replies.