Support » Fixing WordPress » Horizontal lines under page content not workin

  • Resolved courtneycj

    (@courtneycj)


    Hello,
    I’m having trouble with horizontal lines in a table on my WordPress Twenty Eleven website (http://german.berkeley.edu/).

    We used to have lines separating “Links” and “Contacts” from the links beneath them, but a WordPress update wiped all of our customization and I’m having to redo all of the formatting.

    The code shows up correctly when I practice on the w3school website’s TryitEditor, and it jives with what everyone else has written in other forums (and have said works correctly). But when I save the page in my site, the lines don’t show up at all.

    Because it’s a multiuser site on a university server, I’m not allowed ftp access to edit, so I can only access what’s available in the WordPress dashboard.

    Here’s the code I’m using:

    <table width="100%" border="0" cellspacing="0" cellpadding="10">
    <tbody>
    <tr valign="TOP">
    <td style="background-color:#dadada" width="45%"><strong>Links</strong><hr>
    <a title="Graduate" href="http://german.berkeley.edu/graduate/">Prospective Graduate Students</a>
    <a href="http://mgp.berkeley.edu/">Multicultural Germany Project</a>
    <a href="http://german.berkeley.edu/transit/">TRANSIT</a>
    <a href="http://townsendcenter.berkeley.edu/">Townsend Center</a>
    <a title="Institute for European Studies" href="http://ies.berkeley.edu/europeanlanguages/">Languages of Europe</a>
    <a href="http://ls.berkeley.edu/about-college/l-s-divisions/arts-humanities">Arts and Humanities</a></td>
    
    <td style="background-color:#c3c3c3" width="55%"><strong>Contacts</strong><hr>
    <a href="/administration/">Advising</a>
    <a href="/administration/">Administration</a>
    <a href="/study-abroad/">Study Abroad</a>
    <a href="/placement-guidelines/">Language Placement</a></td>
    </tr>
    </tbody>
    </table>

    I’ve also tried using <hr /> instead of <hr>, or leaving out the before <hr>. Nothing works.

    Any help would be greatly appreciated!

Viewing 4 replies - 1 through 4 (of 4 total)
  • That didn’t work. Here’s the code properly this time:

    <table width="100%" border="0" cellspacing="0" cellpadding="10">
    <tbody>
    <tr valign="TOP">
    <td style="background-color:#dadada" width="45%"><strong>Links</strong><br><hr>
    <a title="Graduate" href="http://german.berkeley.edu/graduate/">Prospective Graduate Students</a><br>
    <a href="http://mgp.berkeley.edu/" target="_blank">Multicultural Germany Project</a><br>
    <a href="http://german.berkeley.edu/transit/" target="_blank">TRANSIT</a><br>
    <a href="http://townsendcenter.berkeley.edu/" target="_blank">Townsend Center</a><br>
    <a title="Institute for European Studies" href="http://ies.berkeley.edu/europeanlanguages/" target="_blank">Languages of Europe</a><br>
    <a href="http://ls.berkeley.edu/about-college/l-s-divisions/arts-humanities" target="_blank">Arts and Humanities</a></td>
    
    <td style="background-color:#c3c3c3" width="55%"><strong>Contacts</strong><br><hr>
    <a href="/administration/">Advising</a><br>
    <a href="/administration/">Administration</a><br>
    <a href="/study-abroad/">Study Abroad</a><br>
    <a href="/placement-guidelines/">Language Placement</a></td>
    </tr>
    </tbody>
    </table>

    This CSS is why the <hr> isn’t showing up –

    hr {
        background-color: rgba(0, 0, 0, 0);
    }

    Looks like it’s from a style.css file that you probably can’t access. Do you have access to this one?:

    hr {
        background-color: #E7E7E7 !important;
        border: 0 none;
        clear: both;
        height: 1px;
        margin-bottom: 18px;
    }

    Try adding !important to the background color.

    Thanks for responding, WPyogi. I don’t think I have access to the code you provided above. I can only write code in the text editor for pages and in the “Advanced Options” section under Appearance/2010 Weaver. I’m trying to get ftp access, and if I do I’ll try to fix the style.css file. In the meantime, is there no way to force the line to appear in the table’s coding?
    Thank you!

    To follow up, I was able to get FTP access and used the code you suggested, WPyogi. Problem is fixed now. Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Horizontal lines under page content not workin’ is closed to new replies.