Support » Plugin: Contact Form 7 Honeypot » HoneyPot Tag

  • Resolved LordLiverpool

    (@lordliverpool)


    Hello Honeypot

    I installed your plugin.

    I added the shortcode to my CF7 Form.

    I changed the name of the tag from honeypot-388 to website-388.
    As recommended in your instructions.

    So the full shortcode now reads as:

    [honeypot website-388]

    Have I done this correctly? Will “honeypot” be stripped out now?

    (see image)

    Honeypot photo honeypot_zpsuvo6vts3.jpg

    If I view the source I can spot HP on the span id.
    Is this a giveaway for Honeypot?

    <p><span id="hp5c45c6191e7ce" class="wpcf7-form-control-wrap website-388-wrap" style="display:none !important; visibility:hidden !important;"><label class="hp-message">Please leave this field empty.</label><input class="wpcf7-form-control wpcf7-text" type="text" name="website-388" value="" size="40" tabindex="-1" autocomplete="nope" /></span></p>

    Thanks in advance.

    Kind Regards.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ryan

    (@daobydesign)

    Yes, as you can see from the source, the term “honeypot” isn’t displayed. It’s just the name of the tag.

    The “hp-” as message class prefix is used for uniqueness so that the HP message CSS can be overridden if desired. Changing this would require either checking the “Disable accessibility label” option when generating the form tag, or altering the HTML output (more info here).

    The ID with “hp” in it was a way to use a unique ID and I had originally felt it was sufficiently masked (IDs in CSS can’t start with a number). I’ve just released the latest version of the plugin that changes this to the more plugin-specific, but Honeypot generic “wpcf7-” prefix instead. Simply update the plugin and you should notice the change. I’ve also included a way to override that value with a user-defined value.

    @daobydesign

    Hi Ryan,

    Thanks for getting back to me so quickly.

    So I updated your plugin to version 1.14 and the hp prefix has gone from the span id.

    <p><span id="wpcf7-5c4607e6536ba" class="wpcf7-form-control-wrap website-388-wrap" style="display:none !important; visibility:hidden !important;"><label class="hp-message">Please leave this field empty.</label><input class="wpcf7-form-control wpcf7-text" type="text" name="website-388" value="" size="40" tabindex="-1" autocomplete="nope" /></span></p>

    Thank you very much for your help, it’s greatly appreciated.

    I’ve just left you a 5-star review. Thank you.

    https://wordpress.org/support/topic/great-plugin-20529/#new-post

    Kind Regards.

    Plugin Author Ryan

    (@daobydesign)

    Very much appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.