Support » Plugin: Advanced Forms » Honeypot field

  • Resolved ben_nz

    (@ben_nz)


    The honeypot field named email_for_non_humans seems to display by default.

    In my opinion it should be hidden by default.

    Have used CSS to hide on my site.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author fabianlindfors

    (@fabianlindfors)

    Hi, Ben! It should be hidden by default. The input should be nested inside a hidden div. Could you check if there is such a div in your form?

    Thanks!

    Just took a look and I notice that it does appear to be in a div of class acf-hidden, but for some reason I don’t actually seem to have any associated CSS preventing display of that class.

    Plugin Author fabianlindfors

    (@fabianlindfors)

    Weird!

    The style should come from a stylesheet called acf-global.css. Could you check if it’s loaded on the site? Also, could you check if the acf-input.css CSS is loaded as well?

    Completely forgot that I had disabled loading of the acf stylesheets! Thanks for helping out, and sorry for taking your time.

    Plugin Author fabianlindfors

    (@fabianlindfors)

    I see! I’ve been thinking about adding a display: none to the markup but I’m afraid some bots may be able to detect that. Going to look into it! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Honeypot field’ is closed to new replies.