Support » Plugin: Caldera Forms - More Than Contact Forms » Spam Prevention Not Working?

  • Getting tons of spam now even with Conditions on certain words and characters set to deactivate the SEND button.

    The form does have “Enable : Uses an anti-spam honeypot” on.

    But lots of spam seems to be flowing around both measures.

    So are these forms devoid of any spam protection now?

    • This topic was modified 2 months, 3 weeks ago by sdagency.
Viewing 5 replies - 1 through 5 (of 5 total)
  • This has never worked for us, we needed to use the additional plugin Caldera Forms Anti-spam. would be nice if Caldera would actually support native reCaptcha V3.

    Thread Starter sdagency

    (@sdagency)

    Thanks Chad. Most of the recent reviews for that plugin say it doesn’t work. Too bad.

    Russian spam is bypassing normal form submission. I have tried numerous spam prevention plugins and used the Caldera forms recaptcha v3, but no change. The submissions go to my email, but don’t show up in the submitted form entries.
    It somehow seems like a critical security issue if these bots can bypass normal submission protocols. I changed the contact form page URL this morning to see if that helps, but that may affect backlinks from some of my other sites.
    Any ideas out there how to prevent the Russian spam attack?

    Thread Starter sdagency

    (@sdagency)

    Looks like a new release of Caldera just came out. Not sure if any of this will fix the spam, but maybe?

    “`Caldera Forms 1.9.4 fixes compatibility issues and jQuery upgrade issues.

    make sure the field edition process ( in @calderajs package ) is passed all data required
    dequeue jQuery 1.12.4
    changed deprecated jQuery events
    call jQuery instead of $
    add a js click event to reTrigger baldrickTrigger events ( jQuery update seem not to listen to baldrick events for DOM elements that are not shown on the first pageload )
    add an html onClick event to call baldrickTrigger on the view entry button
    Add ‘permission_callback’ => TRUE to tokens.php and crud.php`”

    I set up conditions too to check for certain word and hide the send button. Worked great for me but somehow the spammer could still send it. Spam was emailed to me and it was in the submissions list. I realized that my auto responder could be sending that spam to a valid email (not the spammer) so I disabled auto respond.

    Switched to Ninja Forms and that stopped it. I might switch back to see if the update fixes it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.