Support » Plugin: Yoast SEO » Homepage translation issue since update to 14.1

  • Resolved bluisier

    (@bluisier)


    Hi,

    I use Polylang as translation plugin on my website.

    After updating to Yoast 14.1, I did some checks as I knew this was a sensible update. After checking some posts, pages, categories… everything was fine but my home page which was displaying title tag and meta description in english.

    So I went to yoast seo settings -> search appearance -> and updated the title and meta description for the home page. After saving, the tags on my french homepage where generated correctly… but now the tags on my English homepage (linked) are not translated anymore. Of cours I made sure that the string translations are set right in my languages settings.

    Do you have any idea how I can make that work again?

    Oh and on last thing, I also noticed that <meta property=”og:locale:alternate” content=””> disappeared compared to 13.5 version. Is it normal?

    Thanks for your help

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @bluisier,

    Polylang is working on a solution to this issue and you can follow the progress here: https://github.com/polylang/polylang/pull/491

    If you are using WPML or PolyLang, we would suggest temporarily reverting to version 13.5 of the Yoast SEO plugin until the developers of the respective plugins release an update for compatibility with Yoast SEO version 14.

    You can revert back to the 13.5 version by downloading it and then performing a manual update of the plugin. We strongly recommend making a complete backup of your site or testing this on a staging site.

    You can download version 13.5 by performing the following steps:

    • ​Visit https://wordpress.org/plugins/wordpress-seo/advanced/
    • Click on the ‘Advanced View’ option (this is beneath the plugin version information near the bottom)
    • Under ‘Previous Version’ select the 13.5 version
    • ​Click the ‘Download’ button.
    • After downloading the 13.5 version of the plugin, you would next need to perform a manual update of the plugin. We have instructions here: https://kb.yoast.com/kb/how-can-i-update-my-free-plugin/#ftp.

      You will need an FTP program such as FileZilla and your FTP details, which can be obtained from your host provider.

    Thread Starter bluisier

    (@bluisier)

    Hi @priscillamc,

    Thanks for your answer.

    ok if I go back to 13.5 there wont be any issue with the new database structure introduced in yoast 14+???

    anyway, from what I tested I have this issue only if the homepage is defined as “my latest post” in the wp settings and only on the translated version of my homepage. The <meta property=”og:locale:alternate” content=””> is not there anymore but is just a facebook tag right… should not have any impact on google SEO. I can maybe just wait for the fix with Yoast 14.1

    Thread Starter bluisier

    (@bluisier)

    Another thing that might be related is that I’m also missing the string translations for the yoast social media settings for facebook on the front page (title and description)… is it an issue on yoast side or polylang side?

    Thread Starter bluisier

    (@bluisier)

    Hi @priscillamc,

    Well according to the Polylang developer, it seems the issue is rather on your side.

    see his replies here (https://github.com/polylang/polylang/pull/491) and here (https://github.com/polylang/polylang/issues/505#issuecomment-629113741).

    Do you have any timeline for this? I mean… I guess tons of people use yoast with Polylang or WPML right?

    Plugin Support Michael Tina

    (@mikes41720)

    @bluisier there’s been a response as to how the integration with the multilingual plugins has changed. We’re waiting on Polylang for an update for the fix, but as of the moment, the Yoast SEO plugin is compatible with the WPML plugin.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    This thread has been marked as resolved due to a lack of activity. You’re always welcome to re-open this topic.

    Thanks for understanding!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Homepage translation issue since update to 14.1’ is closed to new replies.