WordPress.org

Support

Support » Plugins and Hacks » Homepage title issue after upraded to 2.0.1

Homepage title issue after upraded to 2.0.1

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Steve Mortiboy

    @wpsmort

    Support Manager at Semper Fi

    Do you have a URL where we can see this problem? If we can see a specific example we can help you troubleshoot it.

    Same issue when update to 2.0.2
    On front page I use static page.
    With 2.0.0 tittle was taken from AIOSP settings.
    With 2.0.1 (and 2.0.2) tittle like Static page name + general reading setting from WP… And I can’t change it. Downgrade to 2.0.0 and all fine

    I’ve had the same problem since 2.0 came out.

    In the end, I change the title tag in my theme to include the following:

    <?php if(is_home()) echo 'Your blog title here'; else wp_title(); ?>

    Plugin Author Steve Mortiboy

    @wpsmort

    Support Manager at Semper Fi

    Hi Ivan, The title, description and keywords for the homepage has always been taken from the Home Title, Home Description and Home Keywords fields in All in One SEO Pack, General Settings screen regardless of whether you have a static homepage or your blog posts show on your homepage. This code has never changed and continues to work fine when we test it.

    We typically see problems with themes that try to overwrite what All in One SEO Pack outputs because the theme usually loads after the plugin. Check and make sure your theme isn’t doing something to overwrite All in One’s meta.

    Actually, I’m going to correct myself. Version 2.0 of the plug-in was fine – 2.0.1 introduced the problem.

    Nothing has changed in my theme. Indeed, the problem still arises if I use the default WordPress theme, Twenty Twelve, so it’s not a plug-in issue.

    If I set a post as sticky, the homepage’s title will become the title of that post. If I haven’t got a sticky post selected, the homepage’s title will be that of the most recent post.

    This happens no matter what options I select in the plug-in’s settings page.

    Plugin Author Steve Mortiboy

    @wpsmort

    Support Manager at Semper Fi

    Hi iwords,

    Can you post the URL for your site so we can see this problem.

    http://www.testdriven.co.uk/

    I’ve temporarily taken out my fix (as mentioned above), so you’ll see the homepage’s title will be that of the sticky post.

    I have fix the issue by revert back to 1.6.x.x version and it’s all done. Waiting for the next update to see if it could be any better. My url is http://www.mybestratedwebhosting.com but you may not see the issue right now since I made the fix the way I mentioned. However I will see how testdriven.co.uk would be fixed since they have the same problem like me.

    Plugin Author Steve Mortiboy

    @wpsmort

    Support Manager at Semper Fi

    Hi iwords,
    What do you have set in the Home Description field on the General Settings screen in All in One SEO Pack?

    Home Title: TestDriven – UK-based car news, reviews and road tests, updated daily

    Home Description: Created by a group of freelance journalists tired with the way established motoring publications focus their content on the experience of driving rather than owning, TestDriven aims to produce reviews that are more critical of each manufacturers efforts.

    I’ve only just noticed – that means the plug-in is also incorrectly setting the homepage’s meta description and keywords to be that of the most recent (or sticky) post.

    Just like Szperm, I reverted back to this version http://downloads.wordpress.org/plugin/all-in-one-seo-pack.1.6.15.3.zip and the problem has gone away.

    Any luck tracking this down, wpsmort?

    I’m going to revert to a previous version in the meantime.

    With regards to the problem I experienced, everything was working fine on the desktop theme but on the mobile theme (I use mobilepress plugin) the home page kept showing the title of the first blog post entry on the site.

    I, too, experience the same issue, post v2.0.1.

    On the homepage, the title, meta description and meta keywords are pulling from the most recent post in the loop – rather than than the configured Home Page Settings. I can confirm that this happens both with my custom theme and with the default theme.

    Plugin Contributor Peter Baylies

    @pbaylies

    cliquenoir,

    What do you have selected for all your settings under Settings -> Reading -> Front Page Displays…, and what version of WordPress are you using?

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Homepage title issue after upraded to 2.0.1’ is closed to new replies.