Support » Plugin: Content Views - Post Grid & List for WordPress » Homepage slider is visibly slow

  • Resolved kiaseven

    (@kiaseven)


    Hi,

    We have Content Views Pro and it’s a great plugin – thank you.

    One issue we’ve had forever is that the homepage slider is very slow to load. When you first load it, there are no images and it takes a second to fill out, resulting in a rather unappealing first impression.

    We optimise our images so I don’t *think* this is the issue. Are you able to help please?

    Kia

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Content Views

    (@pt-guy)

    Hi Kia,
    Thank you for contacting us.
    I checked your homepage and found that the images are lazy loaded by theme, or another plugin. So slider is not visible at beginning.
    Please disable any lazyload feature of theme or another plugin.
    Best regards,

    kiaseven

    (@kiaseven)

    Hi, I have disabled Lazy Load by WP Rocket but I should say that this slow-load effect was happening even before we installed the plugin (and is still happening now). Do you have any ideas please?

    Thank you,

    Kia

    Plugin Author Content Views

    (@pt-guy)

    Hi Kia,
    Images take time to load, it is not possible to see them immediately when you visit the page.
    To have a placeholder space waiting for images to loaded, Please add this code to Custom CSS field (the left textarea) in Content Views >> Settings page:

    
    @media (min-width: 992px) {
    #pt-cv-view-fbd6acb2vr .pt-cv-href-thumbnail {background: #ececec; min-height: 385px; display: block; width: 100%;}
    }
    

    Best regards,

    ng63

    (@ng63)

    Hi Kia,
    Not an expert and not sure if related to content views pro (I only have the free version) but I can see on the Pingdom Website speed test (I think) that the SAME You Tube video player javascript is loading 5 times (i.e once for each of the 5 videos displayed on the home page which equals 5 x 400KB =2mb of script !!) which isn’t right. (only needs to load once =400kb)

    Also your home page slider images total approx 4MB which is somewhat chunky…you could run your original images through tinyjpg.com or use GIMP to reduce the size manually to your satisfaction.
    Hope this helps you
    Neil

    kiaseven

    (@kiaseven)

    @pt-guy, thank you for your help.

    @ng63, thank you Neil. We’ve deleted the videos off the homepage. We’ve also installed EWWW Image Optimiser to optimise images on the fly. Before this, we were ‘saving for web’ via Photoshop and using ImageOptim to reduce image size but I don’t think this has done a great job. Hopefully, we’ll see some improvements.

    Thank you,

    Kia

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.