Support » Plugin: Polylang » Homepage problem with Polylang

  • Resolved befrenchie

    (@befrenchie)


    Good morning,

    I use Polylang to translate my website. I’m very happy of this great plugin and I would like to thanks Chouby and all the contributors, it’s so useful. Unfortunately since a week I do experiment a problem.

    My website, http://www.befrenchie.fr is setup in French & English.

    But a problem appears, now, when I activate Polylang plugin, the homepage redirect directly to this post : http://www.befrenchie.fr/fr/diy-lampe-boites-fargton-ikea/ (it isn’t the last article) and if I click “home”, it makes a loop and I’m still redirected on this page. When I desactivate Polylang, all come back in place, but I have the copy of all posts in French & English. As I can’t fix it, I have let it like that for the moment but I hope to find a solution.

    So now I’m forced to desactivate Polyland because if I activate it, visitors can’t see all posts and are constrained to go in the differents categories.

    To understand this problem, here a video showing it :
    https://youtu.be/BEERF75sx4o

    Thanks you very much

    https://wordpress.org/plugins/polylang/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Chrystl

    (@chrystl)

    Hi
    Which update have you done before the problem appears (theme, which plugins …)? Did you add some custom code?

    Hi Chrysti,

    the blog is under WordPress 4.4, plugins are all updated. Here is the list of installed plugins :

    Google Analytics by Yoast
    Yoast SEO
    Jay essential ( I use Jay theme )
    Redirection
    Twenty-Twenty
    WP Rocket
    WPS Hide Login

    And I don’t have custom code.

    Have a nice day,
    Daphne

    Plugin Support Chrystl

    (@chrystl)

    Which Polylang version do you use?

    I always update Polylang when a update is available, so I’m with Polylang 1.8

    Thanks

    Plugin Support Chrystl

    (@chrystl)

    Could you please deactivate all plugins, except Polylang. Then test your theme + Polylang 1.8.
    If it works activate your other plugins one by one to see which one might be interfering.

    It was obvious in fact !

    The error was caused by “Redirection” (I use it for monitoring 404 errors) plugin who autmaticly settuped a 301 redirection from befrenchie.fr/fr and befrenchie.fr/en to the article.

    Sorry for disturbing the forum for that 🙂

    Resolved

    Caused by Redirection plugin

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Homepage problem with Polylang’ is closed to new replies.