Support » Fixing WordPress » Homepage post font is bold, post font is not

  • Resolved thephotorebel

    (@thephotorebel)


    I am having an issue with my theme. When making a post, on my home page all font shows as bold, yet when clicking view post, the font looks correct as I had originally planned it. As well my about us text and plenty others are bold and I’d rather they weren’t. Just to reiterate, the issue is only on my home page for the posts, but on my sidebar the fonts are bold no matter where i navigate to.

    I corrected some 404 errors with fonts asking for the wrong folder, but it didn’t change anything.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • I can see three instances of the opening HTML tag for bold <strong> within the excerpts on your homepage… but without the corresponding ending tag </strong>.

    As the problem is in your excerpts, you’ll find the same issue wherever excerpts are used: search results, category pages, daily/monthly/yearly archives, etc (you’ll only see it if you have two or more posts).

    A normal WordPress excerpt strips off all HTML code from the auto-generated excerpt.

    But it appears your theme (or whatever you’re using to generate these excerpts) is keeping the HTML code in the generated excerpts. And as you have bold text at the beginning of your posts, your excepts include the beginning code for bold, but it cuts off before the closing code for bold.

    As you’re using a commercial theme, we’re unable to do any tests to find out what exactly is going on behind the scenes and help you, as we don’t have access to the code for the theme.

    You’ll have to reach out to your theme’s author for assistance with this.

Viewing 1 replies (of 1 total)
  • The topic ‘Homepage post font is bold, post font is not’ is closed to new replies.