WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Homepage Incorrectly Redirecting to Alternate URL

[Resolved] Homepage Incorrectly Redirecting to Alternate URL

  • Hi,

    I’m fairly new to WordPress and would appreciate help in getting my website up again. Here’s the issue:

    I created a new Page and added a Page Link to an alternate URL. Saved it and added it the menu.

    I didn’t see that the page went to the top of the menu list (as all other pages normally went to the bottom and I moved them into their correct location)., and so I added the page again, moved it and saved the menu.

    SO: I accidentally added two pages with this link to an alternate URL. One was at the top of the menu, and one was in the correct nested location within the menu.

    When I checked the website, the entire site–from the main URL–now links to this alternate URL and I can’t resolve it.

    I have deleted both of the pages with the Page Link, but the website still automatically redirects.

    Appreciate any advice in getting this resolved.

Viewing 15 replies - 1 through 15 (of 23 total)
  • In the Appearance Menus I just found this:

    Home: Class Schedule

    Clearly the homepage has been set to Class Schedule which is why it’s automatically linking. Anyone know how to remove this?

    esmi

    @esmi

    Forum Moderator

    See Settings -> Reading. Then update your custom menu.

    The homepage was a template homepage and not a page I created. I just updated content and images on the WordPress homepage and created new pages to populate the menu.

    In the Settings -> Reading, the options are for me to direct the Front Page to a page I created.

    I just got in through a sub page and the HOME tab has gone from my top navigation menu.

    When I loaded the Class Schedule it somehow replaced the Home page, which is why it’s redirecting.

    The Appearance Menu shows this: Home: Class Schedule

    I don’t know how to unlink or undo this action to get the Home page correcting showing.

    esmi

    @esmi

    Forum Moderator

    Site url?

    esmi

    @esmi

    Forum Moderator

    Are you sure you actually published your new home page? If so, what is its id?

    That’s the thing, I didn’t publish a new homepage.

    When I added a subpage (Class Schedule) through the Appearance Menu settings, it went to the top. Every other time I’ve added a page it went to the bottom and I moved it to the desired location. For some reason the page went to the top and got linked to the homepage. I’m completely at a loss for what to do, but at least I’ve identified the issue.

    esmi

    @esmi

    Forum Moderator

    I didn’t publish a new homepage

    Well try publishing one now.

    But I don’t have the file – it was a template. I don’t know how to locate the homepage file – it was never one I published.

    esmi

    @esmi

    Forum Moderator

    First, switch to the Twenty Eleven theme.

    If I activate that theme, will I loose all of my content on theme 1438?

    esmi

    @esmi

    Forum Moderator

    You shouldn’t do.

    Ok I activated the other theme. It’s now showing.

    esmi

    @esmi

    Forum Moderator

    So the problem is specific to your original theme. Where did you download this theme from?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] Homepage Incorrectly Redirecting to Alternate URL’ is closed to new replies.
Skip to toolbar