Support » Plugin: Yoast SEO » homepage forced to use trailing slash

  • Resolved muchmuch11

    (@muchmuch11)


    my homepage forced to use trailing slash, and now on my sitemap (from Yoast) there are 2 homepage URLs, example.com and example.com/

    how to fix this? previously my homepage don’t have trailing slash, I want it stay that way.
    thanks!

    https://wordpress.org/plugins/wordpress-seo/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Nile Flores

    (@blondishnet)

    Yoast Support

    Hi muchmuch11!

    This is something you don’t need to worry about because search engines actually consider both versions of your homepage (with and without trailing slash) just equivalent. That being said, you should be able to change the canonical link of your hompage under the Advanced tab of the Yoast metabox if your homepage is set as it’s own page.

    In the case you don’t have your homepage’s settings on a page, go to your General settings in your WordPress admin, and you can remove the trailing slash if one is there.

    muchmuch11

    (@muchmuch11)

    On my WP general settings, it’s already without slash. I can change canonical of my homepage, but on sitemap it’s still 2 URLs. If it doesn’t affect SEO, then I’ll leave it be. Thanks!

    AskKim

    (@askkim)

    Yoast Support

    Glad that helped you know how to proceed muchmuch11. Good luck!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘homepage forced to use trailing slash’ is closed to new replies.