WordPress.org

Support

Support » Localhost Installs » Home server WP issues (mostly FTP related)

Home server WP issues (mostly FTP related)

  • I have been slamming my head on my desk about this for far too long. I like to try and figure things out for myself but after two weeks of restarting again and again after I destroy something I’ve decided to ask.

    Here’s how it starts.
    -Ubuntu server 10.04 install, fresh with nothing but OpenSSH installed.
    -update/upgrades done
    -Lamp-server^ installed
    -database configuration goes smoothly
    -latest.tar.gz downloaded, configured contents moved to /var/www
    -install.php runs fine
    -website looks fine and I’m ready to start configuring.

    Here’s where things go wrong. Any plugins, templates, widgets I try to install it asks for FTP access.
    -install vsftpd
    I’m lost. I’ve been googling FTP permissions for two weeks now and nothing seems to be giving me the right instructions.

    What I want to do is give the username “greg” read/write access to /var/www without breaking it.
    The last time I tried the chown command I lost permissions just to view the site from a web browser and couldn’t seem to get them back.

    This actually started the instant I switched from 3.2.1. I didn’t jump on the issue right away because it was just a home server that doesn’t serve much of a purpose other than a learning tool when I feel like playing around.

    I’m assuming I’m only missing one or two steps in giving permissions to “greg” to access /var/www

    Any help would be appreciated.
    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • This should do the trick (you might need to update the path of wp-content)
    chmod a+rw /var/www/wp-content/

    If this works, I’m going to cry because it’ll mean I’ve been googling the wrong issue all along.

    I’ll get back to you on this in about an hour. I just tried to dropped my only user’s sudo privileges by accident so I’m reloading.

    I’m so thankful for scripting!

    That did not work, unfortunately.
    When updating a plugin, it says it can’t remove the old version.
    When changing a theme it says it cannot create the directory.

    I’m so confused.

    esmi

    @esmi

    Forum Moderator

    Why don’t you just download the plugins & themes, unpack them and then drop them into the relevant folder?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Home server WP issues (mostly FTP related)’ is closed to new replies.
Skip to toolbar