WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] home pagination '/page/2' redirect to a post !!

[Resolved] home pagination '/page/2' redirect to a post !!

Viewing 9 replies - 1 through 9 (of 9 total)
  • ChristiNi

    @christini

    Hi alex-ye,

    Make sure you also check for any .htaccess files that might be sitting above the folder where you installed WordPress. I used a redirect checker on your /page/2/ link and received the following result:

    Checked link: http://scenebreakers.com/page/2/

    Type of redirect: 301 Moved Permanently

    Redirected to: http://scenebreakers.com/tv/2020-nz-2011-10-2
    7-pdtv-xvid-c4tv/

    Hope this helps!

    I search fo all .htaccess files and I can’t find the proplem .

    ChristiNi

    @christini

    Hello again alex-ye,

    If you’re on a Linux server .htaccess is what controls redirects. As you can see from the results of the redirect checker, there is something, somewhere that is redirecting that page. Keep in mind that even an .htaccess file above your document root (usually public_html for main domain) can affect sub folders. Search home directory as well, not just document root.

    Good luck!

    Thank You Again ChristiNi , but it still not working … most the .htaccess files I found is for index options and there isn’t .htaccess file above home directory .

    ChristiNi

    @christini

    Hi alex-ye,

    Do you have any Rewrites in your .htaccess? Also check for any PHP redirects (these would be in PHP file(s) not the .htaccess) or even Meta redriects. I found this info that should provide some more insight:

    http://www.webweaver.nu/html-tips/web-redirection.shtml

    Hope this helps!

    Thank You AGAIN , Before you say some thing about .htacess files please try this on your local host ..

    I use Appserv 2.5.10 as my local host ..

    0 – enable mod_rewrite on your Appserv .
    1 – change parmlink structure to “%category%/%postname%”
    2 – Create a catgory with slug “tv” as example .
    3 – create a post with slug “2012-worldcup” like example 🙂
    4 – Make sure you have more than 10 posts to show the pagination .
    5 – Clear history and Restart your Appserv
    6 – enter this link “localhost/wordpress/page/2”

    What I had got is the proplem above !!
    So Iam not sure if this proplem from the .htacess file or from the WordPress it self !!

    Did you manage to get this figured out?

    –d

    Here’s a fix… I didn’t figure it out, but I thought I would share…

    add_filter(‘redirect_canonical’,’pif_disable_redirect_canonical’);

    function pif_disable_redirect_canonical($redirect_url) {
    if (is_singular(‘pov_channel’)) $redirect_url = false;
    return $redirect_url;
    }

    WOOT!

    –d

    Thank You For Your Helping , but I fix this by reset links strucure .

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] home pagination '/page/2' redirect to a post !!’ is closed to new replies.
Skip to toolbar