Support » Theme: Blossom Coach » Home page title

  • Resolved jenglass

    (@jenglass)


    Hi! Despite the SEO plugin’s title being shown as “Business Growth Coaching Designed For Any Sized Business,” the site is showing only | as the title of the home page. How can I get that changed so I don’t lose the SEO value of the title on the home page?

    Thank you!
    Jennifer

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi @jenglass,

    It is because you haven’t added the site title and description in the Site Identity panel. Please add it via Admin Dashboard > Appearance > Customize > Site Identity.

    Since you are using a logo, you can uncheck the box located below it. It will not show on your site but will fix the issue that you are mentioning.

    I hope this helps. Kindly let me know if this doesn’t resolve your issue.

    Thread Starter jenglass

    (@jenglass)

    Thanks, @blossomthemessupport, for getting back with me. The “site title” option would work if I wanted every page to have the same title which I don’t – the inside pages have their own titles for SEO purposes, but having the Site Title option for the home page forces all of the other pages to have the same page title in there increasing my character count over the 60 recommended characters for the title.

    Is there another option that works for SEO?

    Thanks and happy holidays!
    Jennifer

    Hi @jenglass,

    You can configure the page title within the SEO plugin for each page.

    Thread Starter jenglass

    (@jenglass)

    Thanks, but the “home” page is not the actual page my WP system has as it is part of the theme. That is the only page that either shows as “|” as the title or if I enter in the Site Title, then that goes all the way through the rest of the site.

    Hi @jenglass,

    Can you please explain your issue with the help of the screenshots? Please annotate on the screenshot the result you want to achieve.

    This will help us to quickly analyze your requirement and provide a solution quickly.

    Thread Starter jenglass

    (@jenglass)

    Thanks! I have uploaded the images to https://imgur.com/a/bX0uJiT so you can see what I am trying to do. I hope it is clear from the images what it is that I need.

    Happy New Year!
    Jennifer

    Hi @jenglass,

    Please remove the description in Site Identity and add the title from the SEO plugin for the homepage.

    This should work.

    If it doesn’t kindly contact our SEO expert from here.

    Thread Starter jenglass

    (@jenglass)

    Thanks, but the homepage is not the homepage that shows up as the homepage shown is created from the theme. My “home” page content does not appear anywhere. That’s what I wanted to do, but cannot.

    Hi @jenglass,

    If you want to show your homepage, then you must delete all the widgets added on the homepage via Customizer > Front Page Settings.

    In addition, you also have to disable the banner section.

    If this doesn’t resolve your issue, kindly contact our free dedicated email support team.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Home page title’ is closed to new replies.