Support » Fixing WordPress » Home Page problem

  • Resolved apostolis.ri


    Good evening.
    I face the following problem.
    I installed the max mega menu plugin which allows you to have a menu with the site static pages.
    When I connect to admin panel and I preview page, the home page to is normal, and the plugin works on all pages.
    But when I want to see the page from another pc or mobile browser does not play the plugin and looks spoiled the menu.
    Please note that spoiled seems only to the home page to any other page of the menu is working properly.

    Any idea to fix it?
    I have clean cash but still does not work

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator t-p


    I recommend asking in this plugin’s dedicated support sub-forum for better results so its developers and users can help you with this:

    You mentioned a cache, did you clear your browser’s cache or the site’s cache (if you have one)? You’ll want to double check that you cleared both.

    I am getting a 404 error (not found) on the stylesheet related to the “whitenew” theme for mega-menu. Maybe try using a different theme for mega menu and see if the problem goes away.

    Another thing to try would be to use a different browser on the same computer, that’ll give you an entirely different cache but same screen and internet provider. If it works on one browser and not the other, there could a be a browser conflict or the cache might still be having issues.

    Not sure what the issue is yet, but hope this gets you started.

    The problem is when I am loged in as administrator the plugin works. When I am as guest It doesnt.
    The broblem issues in home page, on the other pages plugin works.

    Strange. I looked around, it’s possible that your CSS isn’t firing

    The default is to load css using admin-ajax.php. I don’t know much about admin-ajax.php, but that whole “admin” thing plus the fact that they recommend “save to filesystem” makes me think you should go ahead and try their recommended (but not default?) setting.

    I looked at this for probably less than a minute, but from what I read – have no idea why they’d want to use Admin Ajax for menu loading, let alone make that as the default option. That might explain why it only displays for administrators.

    Try changing their setting.

    Thanks for your reply Tyler.
    I tried your suggestion but still doesn’t work.
    Its strange because as guest user only in home page and some other pages plugin doesn’t work and in some others pages plugin works excellent.

    Finally the solution was in cashe. I replaced w3plugin with zencache and all
    works right.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Home Page problem’ is closed to new replies.