Support » Fixing WordPress » Home page not showing in pages.

  • I am trying to verify my website with Youtube. it tells me to put a meta tag in the homepage. However the homepage is not showing in the pages area. I have tried SO many different things but nothing works. The home page shows on the appearance – menus option. I have tried deleting and making another custom one but nothing. I have searched google and Youtube but every idea fails. Please help.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi there,

    To add meta tags to your home page, you will need to add them to the header.php template file in your WordPress theme, specifically in the head section near the link for the style sheet. More details on adding meta tags to your site can be found on the Codex page: https://codex.wordpress.org/Meta_Tags_in_WordPress#Putting_Meta_Tags_Back_In

    You can also try using the Plugin called Insert Headers and Footers to easily add a header to your pages. Note that if you end up needing help with this plugin, please go to the support forum for the plugin.

    Hope this helps!

    Thank you for replying so quickly but I need it explained the steps to get to template file in my wordpress theme. Thank you.

    To get to your theme template file, in your dashboard go to Appearance > Editor. In the Theme Files listed on the right, click on Theme Header (header.php).

    Then you can follow the rest of the steps to add the meta tag(s), which are explained on this page.

    Hi. There is no editor option in the Appearance menu. There is a a edit css. There is a editor option in the plug ins menu.

    Ah, I had missed that your site is hosted on WordPress.com (I just noticed in your site footer), which is why you cannot see the editor option.

    Due to the differences between the hosted blogs offered at WordPress.com and the self-hosted and self-installed version of WordPress supported here on WordPress.org, I recommend that you ask your question over at WordPress.com Support.

    Sorry for the confusion, and thank you!

    • This reply was modified 7 months, 4 weeks ago by  Courtney P.K..
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Home page not showing in pages.’ is closed to new replies.