WordPress.org

Support

Support » How-To and Troubleshooting » home page not in page listing.

home page not in page listing.

  • When I view my site it shows a “home”, “blog” and “gallery” page.
    In the page listings in dashboard, it only lists my “blog” page and my “gallery” page. Both of which I created.
    I want my home page set to a static page but since it is not appearing in my page listing I cannot choose it to set it this way.
    If I try to choose the page to set as static page, my only choices are blog and gallery page.
    If I create a home page, then view my site, there’s 2 homes page tabs displaying.
    I’m using twenty twelve theme.
    Thank you for your help

Viewing 7 replies - 1 through 7 (of 7 total)
  • WPyogi
    Forum Moderator

    @wpyogi

    You need to create the page first, then select it as your home page – see:

    http://codex.wordpress.org/Creating_a_Static_Front_Page

    Ok. Thanks. But I tried that. If I create a page and name it “home”, then when I view my site I have 2 Home pages.
    The Home Page that currently displays(that seems to be there by default) when I view my site is not displayed in the page listing in the Dashboard.

    I am trying to edit my home page, but there is no dashboard page listed as “home” for me to edit . which means it is not in the listing to choose as static page.
    How do I edit/see the home page created on the blog if it is not in the page listing in Dashboard?

    WPyogi
    Forum Moderator

    @wpyogi

    Have you set up a custom menu? That lets you control what shows up in the menu –

    http://codex.wordpress.org/WordPress_Menu_User_Guide

    manojrohtela
    Member

    @manojrohtela

    go to your menu and remove home page option from the menu….after that create a new page ….and save it as home page name…after that it will appear in menu option on your dashboard….then add that page to your menu…now view your site…now only a single home page option will display on your site…now this page is also come in listing in static page as a home….

    Thank you! That’s it! I was all over the Dashboard and couldn’t figure it out. Thanks again for your help. I appreciate it.

    soniahollis
    Member

    @soniahollis

    I want my home page to be included in the dashboard where all the other pages are but its not. I cant find it anywhere on my word press admin to edit the main home page text and so have no idea how it was set up. When I click on appearance – customise- static page it shows me the page on the right hand side but there is no way to edit it.I just want it to be editable the same way as all my other pages. If you can help can you explain it in a really easy way!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘home page not in page listing.’ is closed to new replies.