WordPress.org

Forums

Home Page not displaying (7 posts)

  1. Dave22fair
    Member
    Posted 1 year ago #

    Hi,

    The homepage has viewed ok before but has now become difficult to get to.
    I can view the Home page when I use the 'View' option from the dashboard. However, I cannot get to it from the 'Home' tab on the menu. I have done a basic mistake to make this error but cannot find what it is. I have used a standard template. The site is at:-
    http://www.knitonestitchone.com/
    Thanks,
    Dave

  2. bijibuji
    Member
    Posted 1 year ago #

    What are the last changes you have made?
    did you change anything in your theme's folder?
    or in admin panel?which part?

  3. Hi,

    I have made similar mistakes in the past, it is probably because you have some how deseleted your home page as the default WordPress front page. in the dashboard settings you can have WordPress show either a static front page or your latest blog posts on the front/home page of your site. This could have happened in a number of ways, but the easiest way to fix it is to just go back through and set up your Home page again.

    Go to the WordPress dashboard then go to Appearance > Customize, make sure you have your home page selected as 'static' page and then select the page you wish to show up as the default home page ( the default page that shows when you go to knitonestitchone.com)

    in regards to the 'Home' tab not working: go to Appearance > Menus, in here check to make sure you have the correct pages in the main menu, and particularly check to see if the Home page menu tab is indeed the correct page.

    In the past i have created a page called 'Home' and then put that into the menu, only to have deleted it and created a new front page later on, but i forgot to run through and make sure that it was set to be the default static front page and i forgot to put it in the menu.

    For me, the reason the old 'Home' tab did not update automatically is because i had added it as a custom link.

    Remember, setting your home page to be the main WordPress static front page doesn't mean it will be added to the menu, so u have to go and do this manually. Remember to add the home page from the 'Pages' list and not as a custom link as i did.

    hopefully this fix's your problem :)

  4. here is ur missing home page http://www.knitonestitchone.com/home/

  5. Dave22fair
    Member
    Posted 1 year ago #

    Thank you for your help everyone. Julian, I went into Appearance > Customize > Static Front Page which for some reason was set to Your latest posts! I have set it to A static page and the problem is solved!
    I wanted to set the posts page to Blog but it wasn't displayed as an option, only Home. I remembered that I had set the Visibility on all the pages to Private during this developement period and when I reset the Blog page to Public, it worked fine.

    Out of interest, what is the best way to keep a site under wraps until you think it is ready? I have tried putting in a new Temporary Home page with a 'Site in Construction' notice, but this also meant messing about with the menus. I then discovered the Private status and went about setting all the pages. I don't think is the best idea.
    Thanks, Dave

  6. Check out a maintenance or coming soon plugin - for example this one looks good https://wordpress.org/plugins/ultimate-coming-soon-page/ - this plugin will show a 'coming soon' or 'under construction page' to anyone who is NOT logged in and they wont be able to visit any other page unless they login, while you as the administrator can freely browse the website as normal without seeing the coming soon page while logged in

    :) hope that helps :)

  7. in regards to setting a page to show your latest posts, you can select any page and posts will automatically show up at the top of the page you select in the Customise menu.

    If you still can't see the page 'Blog' as an option, try 2 things. First create a new page and call it Blog Page or Blog 2 and see if that shows up as an option.
    Secondly, Go to your 'Blog' page and edit it via the admin dashboard, down the side check to see if you have the 'template' drop down menu in the 'Page Attributes' section which should be under the 'Publish' Section. Some themes have the template drop down menu others don't, if you do select the option 'Blog Page'. now click update or publish

    If you still can't get your posts to show up on a page, then im not sure whats wrong there sorry :(

Topic Closed

This topic has been closed to new replies.

About this Topic