Support » Themes and Templates » Home Page issue

  • When you go to my blog you see a Home page and the page looks fine but when you start browsing the blog, for example go to Furniture and then when you want to go back to that Home page, you see category archives/ Home and even at the bottom it says where it was posted. So it’s like it’s not taking you back to that primary domain but it’s taking you to a post in a category/archives. I was told that I have the Home link pointing to a directory /category/home/, rather than the primary directory, /public_html. How can I change it?

Viewing 15 replies - 1 through 15 (of 19 total)
  • jack randall


    you’ve set home as a category and included it in your menu. if you go to Appearance -> Menus and remove the home link from your menu, save your menu and then go to the Custom Links box and add in the full URL of your site’s homepage with nothing after the .com, give it the label home then add it to your menu. move it into place and then save the menu.

    head back to your site and refresh it in the browser and navigate about a bit and see if that helps…

    I did exactly what you told me to do but it’s not working.

    If you go to Posts -> Categories, do you have a category named Home? If so, try renaming its slug to something like home-2. It’s possible you have a page called Home and a category called Home, both with the same slug, and WordPress is getting them confused.

    Otherwise you might have better luck posting this in How-to and Troubleshooting since this isn’t a theme problem.

    Caroline- changing it to Home 2 is not working either. I posted the same message in How-to and Troubleshooting but they told me to contact the theme developer, because it might be something within a theme. Nobody knows how to fix it.

    jack randall


    just thought, in Settings -> Reading what do you have set as your front page? if you have a static page defined then you can choose the Home Page and it will defailt back to that otherwise if you’re just using it as is it will automatically assume you want blog posts to appear on your homepage and default back to the home category. try that and see if it makes a difference…

    Did you set up a custom menu under Appearance -> Menus? It’s possible you dragged the Home Category into the menu instead of the Home Page.

    I say this because the menu would display only your Pages by default if not configured under Appearance -> Menus. You’re linking to Categories in the menu, so at some point a custom menu was created an assigned to that navigation area.

    If you click the site title, it goes to the appropriate place. So I don’t think it’s a permalinks problem, but a configuration error with the menus.

    theotherlebowski- your first suggestion is working! I just realized I removed the home link from Pages and not categories, that’s why it wasn’t working. Thank you.
    One more question. When you click on any of my categories, for example you go to Furniture- it says Category archives:Furniture, instead of just Furniture, is there a way I can change that too?

    Caroline I wish somebody could go to my dashboard and check all the settings because I’m sure I set something wrong, but for now, if you read the message above, it’s fixed.
    Thank you very much

    Caroline, since you’re here I have one more question related to the patchwork theme. I have a logo that I’m going to use on that blog but I don’t know how to get rid of the frame that’s within the theme? or if I wanted to get rid of the patchwork image completely and make it the tan color that is used in the background, is it possible too?

    jack randall


    for your theme you’ll need to go into the file called archive.php and remove a little bit of text. look for this line

    printf( __( 'Category Archives: %s', 'patchwork' ), '<span>' . single_cat_title( '', false ) . '</span>' );

    delete where it says Category Archives and then save your changes. head back to your main site, hit refresh and see what happens 🙂

    theotherlebowski-Where do I find archive.php? Where is that file?

    theotherlebowski- do I delete that whole line or just category Archives?

    jack randall


    you need to go into Themes -> Editor and on the right you’ll find a dropdown list of the installed themes, select patchworka dn then look down the list of files to find Archive. select it and only delete the two words Category Archive in that line of code only! save the file and then go back to the main site and select a category and see if it’s disappered 😀

    Before you make changes to the theme files, I highly recommend making changes in a child theme instead, so your edits are preserved across theme updates. Also, if you make a mistake, it’s easier to reverse it quickly rather than potentially having to install the theme and start from scratch.

    You can use CSS to change just about anything in the theme–like the header frame’s border or the background image. I haven’t tested this code but it should give you an idea:

    header#masthead {
    background-image: none;
    header#masthead hgroup {
    background-color: transparent;
    border: 0px none;

    I know I’m stupid about all this, but yes it disappeared, thank you very much. I have to remember your name so if I have any questions I will ask you 🙂 Thank you!!!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Home Page issue’ is closed to new replies.