Support » Fixing WordPress » Home page is pointing to a post or category after upgrade

  • Resolved smittenbybritain

    (@smittenbybritain)


    I upgraded to WP 3.0 yesterday and ever since my home page is pointing to a page instead of my URL. Please help. I’ve only been with WP for three months and I have no idea what to do at this point. Can I downgrade back the older version? How do I redirect the homepage to the proper url?

    Thanks.

    Melissa

    http://www.smittenbybritain.com

    By the way, I deactivated all the plug-ins with no effect. Also tried deleting page the home page was pointing to, and the home page just redirected to another page.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Try switching to the default (twentyten) theme?

    Yes, with no improvement.

    what have you set on your settings > reading page?
    wp-admin/options-reading.php

    The reading page is set for the latest posts and not a static page. Also, in General under settings, it is set to the proper url.

    Might see what’s in your index.php in the web-root folder. If necessary, post the contents of that file in a pastebin and report the link back here.

    I just figured it out. I missed the redirection plug-in. After I deactivated it the home page worked. But what do I do with the plug-in now? I need it to redirect my feed from my old Blogger blog.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    We can probably help you do that with .htaccess instead 🙂

    What was the redirection doing? That is what URL was it fixing?

    I was redirecting /feeds/posts/default (my blogger feed) to my feedburner feed.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Put this in your .htaccess, above the WordPress rules, and it will redirect ALL your feeds to FeedBurner, no plugins needed 🙂

    # redirect all wordpress feeds to feedburner
    RewriteCond %{REQUEST_URI}      ^/?(feed.*|rss.*|comments.*)  [NC]
    RewriteCond %{HTTP_USER_AGENT} !^.*(FeedBurner|FeedValidator) [NC]
    RewriteRule ^feed/?.*$          http://feedproxy.google.com/YOURFEED  [L,NC,R=302]
    RewriteRule ^feeds/?.*$          http://feedproxy.google.com/YOURFEED  [L,NC,R=302]
    RewriteRule ^rss/?.*$           http://feedproxy.google.com/YOURFEED  [L,NC,R=302]
    RewriteRule ^wp-rss2.php        http://feedproxy.google.com/YOURFEED    [L,NC,R=302]

    I use this and it’s made for the happy 🙂

    Lee

    (@diondeville)

    You can still use the redirection plugin – re-activate it then check through the redirections the plugin created when you changed post and page URLs. The place to look is under Redirection>Groups>Modified Posts. Delete all redirections that show as a forward slash (/) only.

    That fixed it for me, anyway.

    You’ll fined the same issue might recur whenever you change a post URL.

    So if I use this I should delete my feedburner feedsmith plugin?

    So for sounding stupid, I’m new to WP and all this redirecting gets confusing.

    Thanks for your help.

    Lee

    (@diondeville)

    You could also use the FD Feedburner plugin to redirect your feeds.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    So if I use this I should delete my feedburner feedsmith plugin?

    If you use the .htaccess rules I provided, you don’t need the feedsmith plugin 🙂

    Thank you both so much.

    Since I’m lazy, I used the simple solution which was deleting the / redirects and it worked.

    However, I have copied the code you gave me ipstenu and will use it if the other option stops working.

    You guys have been great!

    Lee

    (@diondeville)

    You’re welcome 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Home page is pointing to a post or category after upgrade’ is closed to new replies.