WordPress.org

Forums

W3 Total Cache
[resolved] Home page don't show new post with W3 Total Cache (2 posts)

  1. qhacerpe
    Member
    Posted 1 year ago #

    In my website I can't see my new post, it just show a cache version of my home page, I honestly think that the problem is with the BROWSER CACHE configuration.

    I have tried EVERYTHING, I have tried every single configuration I could find, but nothing works. I'm starting to think that I have to uninstall the plugin, but I don't want to because is the best I have came across, except for the lack of information about this issue (that I have seen is very common), so I can't understand why there is no solution anywhere.

    I even activate the options:
    DON'T CACHE THE FRONT PAGE - It didn't work
    PURGE FRONT PAGE in Purge Policy - It didn't work

    Can someone help me with this

    https://wordpress.org/plugins/w3-total-cache/

  2. qhacerpe
    Member
    Posted 1 year ago #

    Ok, I already found the solution, I'm going to put it here to help anyone else with the same problem.

    Like I tought the problem was in the BROWSER CACHE option, all you have to do is the following:

    1) Go to BROWSER CACHE
    2) In GENERAL only check the following options:
    * Set Last-Modified header
    * Set expires header
    * Set entity tag (eTag)
    * Set W3 Total Cache header
    * Enable HTTP (gzip) compression

    This way your home page will load because it will tell the browser of your visitors that there is a new version of your page.

    DO NOT use the "Set cache control header", because this options tells the browser to only update your page after a certain amount of time, this can me minutes, hours or days, and I bet that you want you visitors to view your new posts right away.

    Well I hope this will help someone.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic