WordPress.org

Support

Support » Installation » [Resolved] Home page blank – Install page OK

[Resolved] Home page blank – Install page OK

  • I am new to WordPress — installed it in example.com/wordpress. Able to go to example.com/wordpress/wp-admin and General Settings, etc. After downloading a Theme and uploading to Themes in wp-content, I went to View Blog, but got a blank page with no error messages. Using SQL5.

    Any suggestions?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Change to the default theme and see if that clears the problem. If so, then it is a problem with your custom theme…or the way you uploaded it.

    Changed to default theme — Home page still blank with no error messages. Uploaded the other theme to wp-content/themes.

    So in the admin backend, you can activate the default theme but it’s still blank on the front end?

    And by blank you mean a completely blank white screen as opposed to no content?

    http://codex.wordpress.org/Installing_WordPress#Step_4:_Upload_the_files

    Folders should be 0755
    Files 0644

    wag-‘n-bietjie?

    Thanks for the info. I did follow step 4, but your question caused me to take a look where I created the folder called “wordpress.” I noticed I created it under the “public” folder. Should it have been created under the Root folder to give the path as — http://www.xxxx.com/wordpress?

    Further to the previous post, I meant to type example.com/wordpress and not the “link” quoted, which could be regarded as an x-rated website.

    i got exactly the same problem last night. able to set the setting, but the ‘view site’ open the web page a ‘pure’ blank. At one stage i guess it might be some files corrupted during the uploading of the wordpress file and folders.

    Hey,

    If you’re only going to run WP on your domain, I would suggest installing it in the domain root (so you get http://www.yourdomain.org/wp-admin/ etc)

    If you want to run it in a subdomain called blog or wordpress or whatever, you just need to add the path changes to the wp-config file and admin backend as per the install instructions…

    You were correct in installing WP in the public folder as these files are going to be served/do their magic on the part of the server available to the public via your domain on the internet.

    As far as the theme goes, you unzip the theme files (e.g. astro theme) and put them in http://www.yourdomain.org/wp-content/themes/astro/ etc)

    All folders should have 0755 permissions, all files 0644.

    What is your URL?

    Thanks everyone. Since this was a new blog, I cleared the server, and started over. In the process I discovered that in the wp-config.php I did not include the first part of the database name by making the corresponding change under $table_prefix.

    Everything is now working OK.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Home page blank – Install page OK’ is closed to new replies.