Support » Themes and Templates » Home Page and Blog

  • Resolved theidentityshift

    (@theidentityshift)


    I’m having trouble getting my blog to show up on its own page.

    I just installed the WP theme “Responsive.” I had a page in my old theme that I created called “Blog” then under Settings > Reading I changed the front page to display my static page “Home” and the “Posts page” to display the “Blog” page I created. This worked fine. Whenever I posted a new blog post it would post to the “Blog” page.

    However, since installing the “Responsive” theme this does not work. I cannot get it to work. Is there a way to have a unique page that displays all the blog posts? I would like to put that “Blog” page in my custom menu. Is there a way to have a page that will show all the blog posts so I can put it as an option in my menu?

    My site is http://theidentityshift.com/

    Thanks

    mario

Viewing 15 replies - 1 through 15 (of 32 total)
  • Yes, on whatever page you wish to have the entire blog, change the theme template to “blog” or whatever it’s called. I use the same theme and love it. It’s all in the page templates. Note: PAGE not post templates…. as obviously there are no post templates.

    That should work. Then Settings > Reading you have the home page = page displaying posts (using blog page template).

    It’s a little different than a standard theme…. but still works fine.

    Mario,

    You can create a page “called” Blog and use Blog Template. Please see http://themeid.com/forum for more information.

    Thanks,
    Emil

    Thanks bdbolin. That fixed it! BUT now my home page is my blog. I don’t want my home page to be my blog. I want my blog to be on a different page that I can link to and force my visitors to click on in my menu to go to.

    How do I keep my home page as my home page and make the blog a separate page that visitors have to go to via my menu?

    @theidentityshift create a page and name it “Blog” choose either Blog Summary or Full Posts and use that to display your posts. And now that your have a Blog go to Appearance > Theme Options and link your CTA button.

    Most questions such as this one are already answered on our http://themeid.com/forum

    Emil

    Choosing a blog template does *not* show blog posts. It still shows the “hello world” page with the call to action button and the three home page widgets at the bottom.

    How do we get a page to display blog posts?

    I appreciate your response, but the problem I’m having isn’t about changing my default home page.

    My problem is that I cannot get *any* page to display blog posts.

    I know about Settings -> Reading and choosing a page for “front” and another for “posts”, but it doesn’t work.

    Yes, I selected “Blog (*)” as the page template (tried them both), and yes I added the custom css so my front page so it would be similar to the others.

    But my “blog” page will not display posts. It just won’t. It only displays your “Hello World” page.

    I answered in my forum as well 🙂 Anyways, what’s the URL?

    I am baffled by this, so I do appreciate that you continue to respond. Your theme is beautiful. I don’t care for that home page, but the layout and typography are impressive. Thank you for your time.

    I also joined your forum (used a different email) but my post got cut off. So I came back here for now.

    So here is the url: http://johnnyoz.com/

    Here are some things I’ve done/tried:
    1) I have a page called ‘Home Page’, selected as the ‘front page’ in Settings -> Reading
    2) I have a page called ‘Blog’, uses the page template ‘Blog (full)’ and is selected as ‘posts page’ in Settings.
    3) I am using a child theme.
    4) I entered the custom css that you recommended so that my front page will look the same as the others.

    It’s bizarre. I’m reading everyone else saying ‘that did it’, but my blog page just won’t show those posts.

    Ah yes, missed one: please keep your reading settings like this: http://pix.am/AmRU/ second dropdown should be empty, no selection 🙂 (Nothing for Posts page: leave that empty)

    Emil

    Again, thanks. But that won’t accomplish what I’m after. I’m not being clear.

    I don’t want the posts on the front page. I want the posts on some other page. I’m currently calling it ‘Blog Page’, but no matter what I call it, it gives me your Hello World page.

    Ok, I see now. In my case I put ‘Home Page’ as the front page and, as you pointed out, leave the second one blank. What threw me was that in your photo you have ‘Blog’ selected as front with the second one blank.

    It seems that the blog page knows it’s a blog page without wordpress needing to know where to put the posts.

    Ok, thanks again. I’m gonna go play around with your creation. Good stuff.

    awesome!

    Hey,
    I am using responsive theme, I can not get the bottom three widgets to work, I have gone through the widgets, I loaded BLACK Studio tiny MCE plugin to load icons into the widgets, Still nothing . Area 6,7 and 8 do not work. PLease someone HELP.!!!

    Hi,

    Take a look here: http://themeid.com/forum/topic/849/wordpress-video-text-widgets/ and http://themeid.com/forum/topic/509/sidebar-widget-management/ and.

    Also disable Tiny MCE before you widgets start working.

    Thanks,
    Emil

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Home Page and Blog’ is closed to new replies.