WordPress.org

Forums

[resolved] Home doesn't come up in pages (9 posts)

  1. lil j
    Member
    Posted 4 years ago #

    I have the Blend theme. I just downloaded it. The Home page doesn't come up in the dashboard under pages. And when I click on it on the site it just goes to the selected static page. Can I fix this

  2. vtxyzzy
    Member
    Posted 4 years ago #

    I am not clear on exactly what you want. When you select a static page in Admin->Settings->Reading, that becomes your Home page.

    If you do not select a static page, but instead use 'Front page displays Your latest posts', there is no 'Home' Page, the 'Home' link just uses index.php to display the posts.

  3. lil j
    Member
    Posted 4 years ago #

    Under admin-settings-reading to choose which page for front page only about is available no "home" comes up. But in the menu bar on the site there is a "home" to select. I would like to select the "home" for the front page but it doesnt show up to set as front page. Am I missing something?
    thanks

  4. vtxyzzy
    Member
    Posted 4 years ago #

    Yes, you are missing something. The 'Home' in the menu bar is not a real page. As I said earlier:

    If you do not select a static page, but instead use 'Front page displays Your latest posts', there is no 'Home' Page, the 'Home' link just uses index.php to display the posts.

    In order to have a 'Home' to select as the 'Front page displays' => 'Front page:', you must create a Page with the title 'Home'.

    However, you should be aware that when you select a static front page, you must supply a template for it. Do you know how to code a template?

    EDIT: You are not required to code a template, but usually the purpose of a static front page is to show things other than the defaults. That would require a template.

  5. lil j
    Member
    Posted 4 years ago #

    I did make a new page named "home". Then there were two home pages in the menu bar. I just want to make the home page a regular page like the "about" page (not a blog page), then set it as the static page.

  6. vtxyzzy
    Member
    Posted 4 years ago #

    Did you set the Home Page as the static front page? For example, in the TwentyTen theme, if you just create a Page titled 'Home', but don't set it as the static front page, it appears twice in the menu. Once you set it as the static front page, it only appears once.

    Other themes may be different and some will require coding changes to correct the situation. This topic has been discussed many times. Do a google search on 'wordpress support home appears twice' to see some of the solutions.

  7. lil j
    Member
    Posted 4 years ago #

    Thank you for being patient with me. I am using the blend theme. I did as you said and add a new "home" page and set it as the static page but there are two home pages in the menu bar. I will do the google search that you suggested.
    thanks

  8. lil j
    Member
    Posted 4 years ago #

    I was able to get rid of the second "home". After creating the new "home" page and setting it as the static. Went to edit the page at the bottom under "Theme specific options for this page" selected hide in navigation bar and hide in widgets.

    Hoping this will help someone else just starting out.

    thank you vtxyzzy for the help.

  9. vtxyzzy
    Member
    Posted 4 years ago #

    Glad you got it working. Now, please use the dropdown at top right to mark this topic 'Resolved'.

Topic Closed

This topic has been closed to new replies.

About this Topic