Support » Fixing WordPress » Hitting Too many process limit and getting 500 error on HostGator

  • Resolved aisajib

    (@aisajib)


    I’m using HostGator Baby package and currently I have about 4 WordPress sites hosted there. Among them, only two receive traffic but not that much. One of them get about 1,00,000 (less than a million) impressions per month and another receive about 10,000 impressions per month. I don’t think that’s too much that my sites should go down because of hitting process limit.

    You know HostGator has this 25 concurrent process limit, and since a couple of weeks I’m frequently hitting the limit as my site goes offline with a 500 Internal error report. I’ve checked with the support and they asked me to cache my site. So, I installed W3 Total Cache and now using CloudFlare. The site has become faster but the process limit problem is still taking place.

    I guess many people do host their sites with HostGator that receive way too much traffic compared to my simple websites. For your information, here goes my sites and the most recent error logs:

    http://www.androidkothon.com
    http://www.famusmagazine.com
    (Both of these are local sites)

    [Tue Feb 19 11:18:36 2013] [error] [client 141.0.10.192] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”
    [Tue Feb 19 11:18:36 2013] [error] [client 141.0.10.192] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”
    [Tue Feb 19 11:18:35 2013] [error] [client 207.198.112.12] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”
    [Tue Feb 19 11:18:35 2013] [error] [client 207.198.112.12] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/wp-load.php”
    [Tue Feb 19 11:18:34 2013] [error] [client 82.145.211.121] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”, referer: http://www.androidkothon.com/
    [Tue Feb 19 11:18:34 2013] [error] [client 82.145.211.121] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”, referer: http://www.androidkothon.com/
    [Tue Feb 19 11:18:31 2013] [error] [client 101.226.167.241] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”, referer: http://www.androidkothon.com/post-id/2511?shared=email&msg=fail
    [Tue Feb 19 11:18:31 2013] [error] [client 101.226.167.241] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”, referer: http://www.androidkothon.com/post-id/2511?shared=email&msg=fail
    [Tue Feb 19 11:18:31 2013] [error] [client 101.226.167.244] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”, referer: http://www.androidkothon.com/post-id/2428?shared=email&msg=fail
    [Tue Feb 19 11:18:31 2013] [error] [client 101.226.167.244] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”, referer: http://www.androidkothon.com/post-id/2428?shared=email&msg=fail
    [Tue Feb 19 11:09:58 2013] [error] [client 141.0.10.27] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”, referer: http://www.androidkothon.com/post-id/1406
    [Tue Feb 19 11:09:58 2013] [error] [client 141.0.10.27] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/wp-admin/admin-ajax.php”, referer: http://www.androidkothon.com/post-id/1406
    [Tue Feb 19 11:09:55 2013] [error] [client 141.0.8.28] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”
    [Tue Feb 19 11:09:55 2013] [error] [client 180.234.42.100] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”
    [Tue Feb 19 11:09:50 2013] [error] [client 141.0.9.32] SoftException in Application.cpp:641: Could not execute script “/home/aisajib/public_html/index.php”

    I’m not using too many plugins, just a few ones. However, I use http://mysqldumper.net/ to create automated backups of database. Could this be the problem?

    How can I resolve the situation?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Get a vps or dedicated server man, of course you’re going to run into issues with 1m+ hits on shared hosting.

    Dude read first. I have about 1,20,000 hits. Less than a million, written explicitly in my first post.

    Dude simmer. Most western numerical systems use commas or periods every 3 digits.

    120k is still plenty to hammer any shared hosting solution.

    shannonbit

    (@shannonbit)

    aisajib I’m gettin the same problem on Hostgator, so sure is the server.

    bottleneck

    (@bottleneck)

    I feel like a little pawn to compare with such giants above. My site gets 1K (one thousand) visitors on a daily basis. (HostGator, Baby package as well). The Error log is full of the same errors.

    I sorted out those IP’s on my error list. They are mostly bots.

    I just started looking into this matter, not certain what would come next.

    Moderator Andrew Nevins

    (@anevins)

    @bottleneck, you can discuss that on your own thread.

    bottleneck

    (@bottleneck)

    Thanks, Andrew.

    I will.

    I just need some time to work out some positive solution.

    M.

    kalyanbdas

    (@kalyanbdas)

    hello,

    I got the similar prob, with the exact issue and the error code.

    SoftException in Application.cpp:641

    I am now talking to a Hostgator rep and he says, WordPress SEO by Yoast can be issue and suggested me to disable this. Is the actually the culprit?

    BTW: mine is just a 3 month old site with hardly 20 visits everyday. This is the victim site: http://www.klmnweb.com/

    Any help will be appreciative.

    aisajib

    (@aisajib)

    I was told to cache my site. I believe bots are the main culprits.

    bottleneck

    (@bottleneck)

    @kalyanbdas you could prove a rep wrong either right by disabling Yoast and see the difference.

    @aisajib I plan to deny all offending bots via .htaccess to see it.

    kalyanbdas

    (@kalyanbdas)

    @bottleneck, thanks but I am bit confused since I do not wish to disable a plugin as useful as Yoast SEO plugin. but I have disabled their sitemap and install Google XML sitemaps generator.

    But issue remains enigmatic to me. I am not sure what you gonna do with .htaccess file. I am using Bullet proof security which does pretty good as far as .htaccess security is concerned. Moroever, I am on cloudflare which protects my site from spam blots..

    But coming to same point – how to stop this?

    Any advice that works or has anyone been successful with?

    Moderator Andrew Nevins

    (@anevins)

    @kalyanbdas, you can discuss that on your own thread.

    kalyanbdas

    (@kalyanbdas)

    @andrew,

    I have made a post there http://wordpress.org/support/topic/repeated-500-errors-due-to-over-usage?replies=1#post-3926083

    Hope I could find a resolution there. Thanks

    Kalyan

    bottleneck

    (@bottleneck)

    Hey.

    I sorted out and denied the most annoying and useless (IMHO) bots as well as compromised servers hitting my site and exceeding that limit of 25 simultaneous processes.

    A smart rep said that .htaccess directives returning ‘403 Forbidden’ won’t count as processes.

    In other words, denying bots and zombies reduces 500 errors.

    M.

    hotinthenews

    (@hotinthenews)

    Hello;

    I am not here to badmouth anyone just stating facts from personal experience. 18 months ago I decided to get serious with an internet business. I already had a domain name registered with a site hosted on hostgator using their ‘baby gator’ package.

    Before long I started getting server errors several times a day, even though I had less than 500 visitors per day. I was told to install a cache plugin, the tech I spoke with recommended W3 total cache.

    Not long after that same prob all over again. Now I was told that W3 total cache wasn’t really ‘all that ‘ and I should try Super Cache instead.

    That worked for a while. I increased my monthly visitors to about 1,200 and boom same thing. Then hostgator told me I needed to upgrade to a VPs server because I was using too much bandwidth. I did (and paid the extra monthly fee – of course).

    That worked for a little while and once again I got internal server errors. Then a hostgator tech told me I should install a server caching module. I agreed and paid them $35 to have that done. That seemed to solve the problem for exactly one week.

    Once again I was told I needed to upgrade my server to VPS II. I did and once again I paid more money.

    Fast forward. I am now operating on VPS 4 server and today I got an ‘internal server error’. I have presently about 5,000 to 6,000 visitors per day with a monthly page view of 4,600,000.

    If it wasn’t that I am scared to death to transfer my domain to another company because I am afraid I won’t have my wordpress platform properly transferred over (I did a lot of custom programming and wrote a ton of articles) I would have dropped hostgator long time ago.

    Again, not badmouthing anyone, just sharing my personal experience with that company. I have trouble shooting emails from them that fill up several shoeboxes were I to print them out. Amazingly what one tech said I needed to do another tech would tell me not to do and so on.

    I wish you good luck. I am still biting my nails every day with hostgator.

    Lode

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Hitting Too many process limit and getting 500 error on HostGator’ is closed to new replies.