Support » Plugin: WP Statistics » Hit Counts have stopped

  • Resolved jslttery

    (@jslttery)


    The counts were working fine, and then I put a bare IP address into the exclusion list. I eventually spotted that this was an issue and deleted the entry. However the counts are still stopped.

    I also tried restoring to a backup from a week ago, but no luck.

    The current situation is that the Excluded IP Address List is empty, but I’m still getting no visits.

    I’m very much a WP novice, but have found the PHP MyAdmin page and looked through the wp_statistics_* tables and nothing looks amiss. Is there perhaps a permissioning thing I should look at?

    Thanks in advance,

    S.

    https://wordpress.org/plugins/wp-statistics/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Greg Ross

    (@gregross)

    Double check all of the exclusion settings.

    You can also enable the “Record Exclusions” option to see why your hits are getting excluded.

    Thanks for the response Greg.

    As far as I can see there’s no issue with the settings on the Access/Exclusions tab. I’ve enabled Record Exclusions and it does look like the wp_statistics_exclusions table is getting updated. But it only has one line with reason = “browscap” and the count has hit 170 in probably less than a day.

    I’ll have a read about what browscap is, but any other pointers appreciated.

    Cheers,

    S.

    Plugin Contributor Greg Ross

    (@gregross)

    browscap is used to exclude robots from your site stats.

    Have you enabled browscap in the settings?

    If so double check the file size on the browscap.ini file on the optimization page, it should be about 200k.

    I have a number of WP sites I manage for clients (basically half a dozen all with the same theme and plug-in set) all hosted with godaddy. Two days ago, WP Statistics stop recording visits, visitors and search referrals on one (and only one) of these sites.

    Details as follows;

    Resources

    Memory usage in PHP: 7,096,120 Byte

    PHP Memory Limit: 256M
    The memory limit a script is allowed to consume, set in php.ini.
    Number of rows in the wp_statistics_useronline table: 1 Row

    Number of rows in the wp_statistics_visit table: 171 Row

    Number of rows in the wp_statistics_visitor table: 7,273 Row

    Number of rows in the wp_statistics_exclusions table: 575 Row

    Number of rows in the wp_statistics_pages table: 1,436 Row

    Version Info

    WP Statistics Version: 8.1
    The WP Statistics version you are running.
    PHP Version: 5.4.31
    The PHP version you are running.
    PHP Safe Mode: No
    Is PHP Safe Mode active. The GeoIP code is not supported in Safe Mode.
    jQuery Version: 1.11.1
    The jQuery version you are running.
    cURL Version: 7.24.0
    The PHP cURL Extension version you are running. cURL is required for the GeoIP code, if it is not installed GeoIP will be disabled.
    BC Math: Installed
    If the PHP BC Math Extension is installed. BC Math is no longer required for the GeoIP code and is listed here only for historical reasons.

    Have spoken to Godaddy support and there is nothing but green lights on the hosting account.

    Anything else I should check? Any other ideas what could be causing this?

    Marcus

    Plugin Contributor Greg Ross

    (@gregross)

    I found the issue, it’s a bug with the browscap code that cropped up with the last update of the browscap.ini file.

    Version 8.1.1 will fix this after you force a browscap.ini update on the Statistics->Settings->browscap page.

    Yep! That seems to have fixed it.

    I went back to some of the other sites and noticed they did not have browscap usage Activated.

    As a precaution, should we go back to all sites and force the browscap update after updating to 8.1.1?

    It’s back working again after the version update and the browscap update.

    Many thanks Greg.

    Plugin Contributor Greg Ross

    (@gregross)

    If you don’t have browscap enabled there’s no need to update the file, if you even enable it a new version will be downloaded anyway.

    Excellent work. Thanks Greg.

    P.S. Excellent plug-in

    Plugin Contributor Greg Ross

    (@gregross)

    No problem, don’t forget to rate and review us!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Hit Counts have stopped’ is closed to new replies.