Support » Plugin: WebP Converter for Media - Convert WebP & Optimize Images » Higher version of Imagick needed?

  • Resolved vpjm3.0

    (@vpjm30)


    We get the warning message saying “On your server is not installed GD or Imagick library, or installed extension does not support WebP format.” I checked and both extensions are installed. I called our server administrator to check as well and he found that the current stable version of Imagick available (ImageMagick 6.7.2-7 2017-03-22 Q16) does not support WebP. I looked closely at the example server config given in the FAQs and I see it is using ImageMagick 6.9.9-28 Q16 amd64 2018-08-28. The server administrator said since there are so many distributions of bleeding edge versions of Imagick, I should reach out to the plugin developer to see where they got their specific distribution.

Viewing 1 replies (of 1 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @vpjm30,

    Thank you for your message.

    In the FAQ you have the technical requirements. Please focus on the items marked in red – the version given does not matter. The plug-in does not require a specific version, but the proper configuration of the Imagick extension.

    You have it installed, but it does not support the WebP format. And this should be done by your server administrator. I honestly admit that he probably gave you such information, because it is easier for him – he does not have to do anything.

    Please read the FAQ carefully. By using the phpinfo() function you can check what extensions you have and how they are configured. By running this function you will see that you have Imagick, but you will not see in the list of supported formats WebP format.

    In the FAQ, please also send me relevant information so that he can help you. Can you send me your configuration? Are all the elements marked in red also in your configuration?

Viewing 1 replies (of 1 total)
  • The topic ‘Higher version of Imagick needed?’ is closed to new replies.