Support » Plugin: Disqus Comment System » High server load and dsq_sync_forum problem

  • We have to desactivate the Disqus plugin (version 2.84) in our high traffic sites because an issue related to dsq_sync_forum, the wp cron sytem and wp_options table.

    It seems that Disqus plugin overload the wp_option “cron” with a huge amount of dsq_sync_forum entries when it can´t connect with disqus servers (recently i´ve received 503 http error when syncing comments).

    So, the time i activate Disqus the time the server load increase 20x, overfilling wp_options table . Cleaning “cron” row on wp_options did´nt work. Last chance was changing a bit of code in disqus.php

    https://wordpress.org/support/topic/slow-down-website-performance

    to force an hourly sync scheduled event but didn´t work too.

    So, we´re waiting for an update that fixes this problem. Syncing task couldn´t worst performance if disqus servers are down…

    https://wordpress.org/plugins/disqus-comment-system/

Viewing 15 replies - 1 through 15 (of 28 total)
  • +1 have same problem. Slow mysql queries

    Query_time: 2.384466  Lock_time: 0.111503 Rows_sent: 0  Rows_examined: 1
    SET timestamp=1452841511;
    UPDATE <code>wp_options</code> SET <code>option_value</code> = 'a:24744:{i:1452348771;a:1:{s:14:\"dsq_sync_forum\

    even more, I have drop table in wp_options with thousands valuse of dsq_sync_forum and disable plugin, but it creates again with same content

    Sure, i did that too updating with ” the ‘cron’ option_key in wp_options but it didn´t work at all.

    Any ideas? I´m missing Disqus right now but cannot be activated, caused crash to our high-powered server.

    I have decreased avarage load form 5, to 0.2
    In plugin – Disable automated comment importing
    In DB
    UPDATE wp_options SET option_value = '' WHERE option_name = 'cron'

    But, as I understand, disabling syncronisation will stop adding new comments to wordpress DB and make them nonidexable by SE.

    Have looked in DB – it’s writing again new cron jobs for dysc_sync even with turn off setting in plugin.

    Perhaps Disqus has left us behind… i don´t know what to do, i can´t use Disqus to overload our server.

    In the meantime i´ve activated an anti spam plugin on comments, just to stop a tons of spam comments. That´s it, no third party connections and no community features. I miss Disqus :\

    I had the same problem on our site. Basically you need to disable the comments sync completely. I contact disqus support several times over several months and got zero response. We had to use a direct command line command on the server to sync comments manually every few months.

    Also use phpmyadmin to find the cron field and delete all the entries in it. You can use this sql command to find the field:

    Select * from wp_options where Concat(option_name) like “%cron%”

    I just delete everything in that field, wordpress seems to recreate the cron jobs it needs.

    Thank you @leftofcentre!

    I don´t like the idea of sync comments several times a month but it could be a solution. Well set tup on cron system an that´s it 🙂

    One question, when you load “/scripts/import-comments.php” to manually sync the comments, this function isn´t using the cron system, is it?

    I faced the same problem on my site. Server load shot up, memory and cpu usage at peak. Disqus plugin version 2.84

    Nginx log file filled with errors like these

    ***
    016/02/15 17:16:32 [error] 12373#0: *1468425 FastCGI sent in stderr: “PHP message: WordPress database error Lost connection to MySQL server during query for query UPDATE wp_options SET option_value
    ***

    The value of cron option in wp_options bloated up to 400KB. The cronjobs array in options table was filled with “dsq_sync_forum” for thousands of times.

    1. So disabled Disqus comments.
    2. And cleared the cron value using the sql query –
    UPDATE wp_options SET option_value = ” WHERE option_name = ‘cron’

    @leftofcentre pointed out the best fix for this. I´ve applied that, steps:

    1. Activate Disqus again

    2. Configure Disqus (Comments, Disqus, Plugin Settings) and check “Disable automated comment importing “

    3. Empty cron row in wp-options table (“UPDATE wp_options SET option_value = ” WHERE option_name = ‘cron’;“)

    4. If you have W3 Total Cache, modify plugin wp-cli file (“wp-content/plugins/disqus-comment-system/lib/wp-cli.php”) and comment class “DummyWP_Object_Cache”. If not, next step will be useless.

    5. Set up crontab like this:
    0 5 * * * /usr/bin/php -q ~/www/wp-content/plugins/disqus-comment-system/scripts/import-comments.php > /dev/null

    That way allows you to use Disqus comment system with wordpress cron cleaned. The sync between Disqus and WP will be done after your cron task, not everytime wordpress own cron system is running.

    It should be noted that you will need to make sure the cron job points to the proper location of import-comments.php on your server:

    0 5 * * * /usr/bin/php -q ~/www/wp-content/plugins/disqus-comment-system/scripts/import-comments.php > /dev/null

    Not every site will be at ~/www/… so check you get this right!

    I should also mention that I have experienced the same issue as others – our cron variable in wp_options contained 65012 references to dsq_sync_forum which was crashing our site (mysql out of memory errors and high cpu load).

    I believe that something broke with the current Disqus plugin version and WordPress 4.5 – it was only after we upgraded that we started to see this problem. The earliest scheduled reference to dsq_sync_forum in the cron variable correlates exactly with the date we upgraded WordPress.

    Furthermore, I had begun to see Disqus errors when debugging at the site front-end, Disqus was complaining of a syntax error (‘unexpected < symbol’) when it was trying to automatically sync comments (cf_action).

    This seems like an issue Disqus need to address. For now, the fix seems to be to disable automatic syncing in your Disqus settings. Curiously enough, our comments still seem to be kept in sync and I believe this is because dsq_request_handler() is run on WP init.

    I hope somebody from Disqus will add to this thread.

    hey had to search out this problem myself after noticing a ton of dsq_sync_forum requests in my Crontrol.

    I’ve been fighting with my web host for days about getting a completely random cpu spike.

    my site runs at around 0.2 server load all day and then randomly shoots up to 5.0 and gives a 503 error briefly before coming back down and behaving normal again.

    I have gone ahead and disabled automatic comment sync to see if this hopefully prevents it from happening again, although recurrence is only about once per day!?

    do you think this is the issue im having? my site is http://www.rapwave.net and im hosted on a standard 2GB VPS with Green Geeks.

    I am commenting and making note here as well. This plugin and 4.5 were updated sometime around April 22. Since then this error seems to be coming up a lot, and even bringing the database down: mysql_connect(): User XXX already has more than 'max_user_connections' active connections in ~/wp-includes/wp-db.php on line 1515. After discovering this thread I am disabling the plugin to see if error persists. I will report back after enough time has passed to check if this error subsides.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘High server load and dsq_sync_forum problem’ is closed to new replies.