Support » Plugin: Wordfence Security - Firewall & Malware Scan » High Resource Usage / Apache Processes

  • Resolved t.tousif

    (@ttousif)


    Hi
    I am running wordfence in many sites but one of my site has been disabled by the host saying

    “We have had to disable this site due to High Resource Usage, your site has been using up a lot of Apache processes on the server, this causes the server to crash and become unresponsive.”

    On further investigation they found wordfence to be the issue saying the following
    ——————————————————————–
    “You website triggered a massive amount of processes, all which seemingly points to:
    /home/sites/XXXXX/public_html/wp-content/wflogs/attack-data.php

    This also then triggered file locking on the cluster, which it never clears up, as a result your other processes to the same file were hung, waiting on the fist process to clear up it’s file locking which it never did.”
    ———————————————————————-

    I have had to remove wordfence to get the site enabled.
    But I want to to keep wordfence on my site, but cannot until I resolve the cause of this.

    So anything to resolve this issue would help.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter t.tousif

    (@ttousif)

    Hi
    anyone else faced this issue ?

    bluebearmedia

    (@bluebearmedia)

    Have you tried enabling the low-resource usage options in the Wordfence settings?

    wfalaa

    (@wfalaa)

    Hi @ttousif

    My first step would be to look for the reason why this process locked the file and didn’t complete successfully. It could be a file permissions issue, so please delete “wflogs” folder, then refresh any of the plugins’ options page, you will notice that “wflogs” folder has been created again. Now switch the firewall status to “Enabled and Protecting” and recheck this issue.

    Another thing to make sure about is the owner of “wflogs” directory and its files must be the same as the user your web server is running as. (you can double check that with your web host).

    Let me know how it goes,
    Thanks.

    Hello!

    I hope we were successful in helping you resolve your issue with Wordfence! Since we have not heard back from you in the past 2 weeks I will now be marking this support thread as resolved. However, if we still haven’t resolved your issue please reach out to us as we would be more than happy to further assist you!

    Thanks and have a great day!
    Chloe

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘High Resource Usage / Apache Processes’ is closed to new replies.