Support » Plugin: Yoast SEO » High Resource Consumption on Post Deletion

  • Resolved Shekhar

    (@seanlance)


    I am getting an issue with Yoast SEO plugin. I had 2 posts noindex before 3 days. Today I delete them and my website stopped working at the same time. It was showing HTTP 504 status code (Gateway Timeout).

    I am hosting my WordPress website on AWS EC2 T3 Small VPC that includes 2 GB RAM and 2 VCPU with CloudFront active. I have PHP memory limit set to 512M.

    The website is small with only 40 posts. I just have very lightweight plugins enabled. But still it looks like Yoast SEO plugin taking so much resources on post deletion.

    So, I request you to fix this issue on the upcoming version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support amboutwe

    (@amboutwe)

    We’re sorry that you are experiencing problems that might be caused by our plugin!

    Just to be sure, we would like to rule out any plugin or theme conflicts that may occur. The fastest way to do this is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Nineteen

    Test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.

    As we can imagine that you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts.

    I fixed the issue on that day with PHP memory limit set to 768M. But, I had to reboot the instance first. Probably I will upgrade my hosting limits for better performance.

    In regard to deactivating plugins and switching theme, my website was down and I had no access. So it would not be possible to fix that way.

    In my opinion, I believe that occurred because of sitemap feature requiring resources. But still I cannot tell you anything because are providing us best SEO plugin for free to use.

    It would be better for us to try fixing that type of error in our own way. It can be harder to wait for 1 Week 5 days without a proper solution.

    • This reply was modified 6 months, 3 weeks ago by Shekhar.
    MariusG

    (@marius_codeinwp)

    Hi @seanlance,

    We’re happy to hear you managed to solve the issue. However, that amount of RAM usage is not normal for such a small website. We generally recommend setting the memory limit to 256M, as that’s enough for most smaller websites.

    We do recommend performing the conflict check to determine if the issue persists when Yoast SEO is the only active plugin. It might be some other plugin (or a combination) that is causing this spike in resource consumption.

    We’re looking forward to hearing from you.

    Yes, 256M RAM is lots for PHP. At this time my site is just using 44.16M RAM. So, this time I changed memmory_limit to 256M.
    I always try to keep everything good so my site health is at 94%. It just says have a default theme available.
    In case of other plugins, I don’t think they could cause such spike. But Yes my theme is heavyweight with lots of features.
    This issue is already resolved so I don’t think there cloud be anything extra to decide. I am alright with your support and suggestions this time.
    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘High Resource Consumption on Post Deletion’ is closed to new replies.