Support » Plugin: LiteSpeed Cache » High Memory usage

  • Resolved fluiddesk

    (@fluiddesk)


    Hi, I am getting high memory usage with the litespeed cache plugin enabled, if i disable it and re enable the memory useage drops to 140mb but then will gradually increase to over 700mb until i then disable/ renable it or clear all in the database setting. I hope you can help here, thank you!

Viewing 15 replies - 1 through 15 (of 20 total)
  • Thread Starter fluiddesk

    (@fluiddesk)

    This shows the memory usage climbing, then i disabled the plugin and then re-enabled it and it starts climbing back up:

    https://i.imgur.com/yDK8MXy.png

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please provide the report number , you can get it in toolbox -> report -> click “send to LiteSpeed”

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Hey that’s no problem: ALDJEKKP

    I hope you can help resolve this as it’s alittle concerning seeing the memory keep climbing. I have to disable/ re-enable the plugin to bring it down or purge the caches.

    Kind regards,

    Matthew

    • This reply was modified 1 month, 1 week ago by fluiddesk.
    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    you have a lot of options enabled , these options would use memory to run properly

    you can try reset to default setting first , see how it goes

    and generally speaking , unless your provider warns you about the RAM usage, otherwise it should not be of any concern , and mostly , provider already has limitation in place to prevent user to exceed memory

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    That’s correct although before migrating to one of their other servers the memory usage was 130MB – 170MB most times, after the migration the memory usage just keeps climbing , I haven’t changed any settings since the migration

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    well , frankly I don’t have much idea at this moment , can only suspect some options may consumed certain memory though , that’s why I asked you to try use default setting first and see how it goes

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    yeah the default settings are also causing an issue, only does the memory not rise when the plugin is either disabled or the disable all options is enabled within the tools tab.

    I have tried older versions and the latest version of the plugin with the same result.

    I am also getting this error:

    2021-04-01 17:54:00.336234 [NOTICE] [2816925] sendCmdToWatchdog: ‘createcacheroot:1021:/home/database/lscache/’.
    2021-04-01 17:54:00.336312 [NOTICE] [2816922] [2816922] Cmd from child: [createcacheroot:1021:/home/database/lscache/]

    Kind regards,

    Matthew

    • This reply was modified 1 month, 1 week ago by fluiddesk.
    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    I am thinking maybe some conflict with other plugins/themes

    could you please try create a new WP site , and only install it with LSCWP , see if memory gets high ?

    these are not error , but just a notice

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Do you mean a staging site and if so is there a way to monitor the memory usage for just that site, as cpanel shows the combined memory usage of both the live and staging.

    Regards

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    yes , you can create a stage site

    when both sites , OFF LSCWP , note down the memory usage

    then enable LSCWP on stage site , check the memory usage again

    by the way , there is also a plugin called “query monitor” , you could try

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    After testing further in the main site, it is the CSS combine and JS combine settings that are causing the high memory usage.

    The issue is without these enabled my Google mobile test fails as the page loads in a list style rather than the CSS rendering. I did have a previous thread talking about this which the combine setting did help resolve although in turn the memory usage now increases constantly.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    that makes some sense, as when it operates these files, it needs to be loaded into RAM first

    I don’t really have solution for such case , but I assume if your provider doesn’t notify you such thing , then you should not need be to worried about it

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    Hey,

    Thanks for cleaning that up, I guess i am concerned the most just becuase I had the same settings before migrating within the same company yet the memory usage was not growing constantly. Would you say its normal to see a memory usage of 800MB and growing from a small ecommerce wesbite?

    Kind regards

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    not exactly , 800 MB is bit of off , I have checked 2 of my servers , the PHP process itself various somewhere between 50 – 300 MB usage depends on sites

    the cPanel interface just gives vaguely over-all usage

    you still need to have a SSH access to check actual RAM usage for PHP process

    Best regards,

    Thread Starter fluiddesk

    (@fluiddesk)

    yeah i’ve never saw it that high before, its very gradual, it is at 329.4 MB but by the end of the day it will be close to 500MB and in the morning it could be touching 800MB unless i purge all.

    Is checking the php process easy to do via cpanel or to setup SSH access to check it?

    Kind regards

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.