Support » Plugin: Swift Performance Lite » High CPU Usage Follow-up

  • I had opened a previous ticket regarding having hundreds of stuck Swift preload crons and consistently high CPU usage. I have tried the plugin again. This time, the crons aren’t getting stuck and building up like before but I am seeing high CPU usage during preloading whenever the cache is cleared. The only thing different this time is that I removed the Really Simple SSL plugin before reinstalling Swift.

    I installed the most recent version, making sure that the swift-performance folder was deleted prior to the new install and that no .htaccess rules were left from before.

    I am on inMotion Hosting on a shared server.

    When Swift Performance Lite is the only plugin enabled, clearing the cache and the following preload results in around 52% CPU usage. With my other plugins enabled along with Swift, the CPU usage spikes to about 92% when clearing the cache and preloading. I’ve found that if I add an other pages to the Clear Page Cache After Post Update section, the CPU usage seems maxes out higher at 95 to 100%.

    See this screenshot of my usage. The first tall spike is me activating Swift. The second spike is me clearing/preloading the cache.

    https://pasteboard.co/Hg9ANXO.png

    For your information, according to Swift, my cache size is about 50MB. 33.59MB of that is JS files in the cache/swift-performance JS folder.

    Thanks for your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Scottie S

    (@doit686868)

    If you are continually clearing and rebuilding the cache, then yes, it will spike and possibly crash. Especially in a shared environment. You can control how much resources swift uses. Go to settings > optimization > general > Limit simultaneous threads. Check that box and set a number (2-3) and see what works for your setup.

    I am not continually clearing the cache. The spike happens during preload anytime it runs. I did try settings the Limit Simultaneous Threads down to 1 and the CPU still spikes to about 82% regardless. If I disable automatic preload, then just clearing the cache (without preload) doesn’t raise the CPU usage much at all. Not using Preload makes the site pages load slowly after the cache is cleared so this isn’t an option.

    Can I just add that inmotion is really really awful hosting? Switch to another webhost and you’ll have way more resources. Try SiteGround.

    Plugin Author swte

    (@swte)

    Hi,

    Please try to disable Critical CSS

    https://swiftperformance.io/faq/#high-cpu-usage

    I have never had Generate Critical CSS active so that isn’t a solution. I have tried changing the other settings mentioned in the FAQ but CPU usage remains high during prebuild.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘High CPU Usage Follow-up’ is closed to new replies.