Support » Plugin: Wordfence Security » High CPU, external connection, database huge, slow load

  • Hello.

    CPU is very high if you use WordFence Plugin.
    Plugin has a lot of external connection to servers *.wordfence.org.
    Database become very huge.
    Site with high volume of visitors become slow (server become slow with high CPU usage).

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support wfasa

    (@wfasa)

    Hi faca5,
    Thanks for reaching out. That doesn’t sound normal. Please make a post in our support forum here on wordpress.org and our staff will do their very best to help you sort those issues out.

    Users who use WordFence has higher CPU usage of other users.

    One of plugin WordFence or iThemes in the past it make database 3 GB but it should be only 200 MB.

    We recommend that you do serveral testing on your plugin using high volume of traffic. Your plugin set to many record (connection) to MySQL database. CPU is higher then usual (lookup IP address etc…). This is just recommendation to improve your plugins because without all these problems is great.

    @face5, I can’t speak to the many lingering connections to *.wordfence.org, but on the database size please take a look at this thread

    https://wordpress.org/support/topic/expired-transients-in-wp_options-table/

    If you install the WP_Optimize plugin, you can check how many expired transients might be clogging up your database, and clean them up.

    What I could imagine is happening is that if you over time have been under heavy attack from things caught by WordFence, the temporary or “transient” blocks established by WordFence (where an IP is blocked for a specified time-period) could be clogging up your system as they expire and then linger behind in the database.

    But you can look at your options table, either directly through MySQL or phpMyAdmin and check it’s size. OR, as discussed in the linked thread use WP-Optimize to both check and clean it.

    Ok.

    We have already fixed database size with removing old data.

    Thank you!

    So, just for future reference. What was the “old data” in reality?

    Plugin Support wfasa

    (@wfasa)

    faca5,
    If you have so much traffic on your site that it get’s slow from DB writes, you can turn off “Live Traffic”. This stops each visit on your site from being recorded in the database. Again though, we have staff in the forum who help people with these kinds of issues, so please post there next time!

    Best of luck with your sites.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this review.