Support » Plugins » Hiding Pages

  • Hello.

    What I want to do is, create a X number of pages, but I dont whant them to be displayed with all the other pages.

    In fact, I dont want them to be displayed at all.

    I am using the Pool plugin.

    You can check out the site, here:

    See the text on the downloads category?

    I want to create a link to a page with that text (OST, Videos, Sons, etc…) But I dont want it displayed anywhere else.

    Thanks all!

Viewing 15 replies - 1 through 15 (of 17 total)
  • 1. Next time type a complete link (starting with http:// ) so those who want to help don’t have to copy, paste your address.
    2. Pages are displayed by Template_Tags/wp_list_pages – delete that template tag if you don’t want the Pages to be displayed.
    3. Whatever you want to put in the sidebar > open the sidebar.php and edit it in a plain text editor.

    Thanks. Can you explain a little bit more?

    Im not too good with editing .PHPs.

    P.S: Sorry for the bad link! :S

    OK, back to the basics.
    1. The “downloads” on your blog is not a category. Your real blogpost categories are
    CTU Portugal
    2. Obviously those
    Outros – are not links to Pages. When you say “pages” are we talking about the Pages feature of WP or something else, like usual webpages? Who put those words into your sidebar?

    No .. I want to link the OST, Videos, Sons and Outros to pages (WP Pages).

    I just dont want those same Pages, displayed on the Header like all the other pages are.

    Hope I made myself clear.


    It’s the first time you mention the header 🙂
    OK, then back to my first reply. The template tag I linked to in the Codex (BTW, did you read it all before asking your next question??? – because the answer is already there) has an “exclude” parameter. Use it.
    In your header there must be a code
    <?php wp_list_pages(); ?>

    make it like
    <?php wp_list_pages('exclude=XX,YY'); ?>
    where XX and YY would be the page_id for the Pages you don’t want to show.

    Ok! Ill give that a try and Ill let you know in 5 or 6 minutes.

    Thank you VERY MUCH!

    WORKS! 😀

    Just one thing … I get this text “Pages”

    On the black.

    Its still there. Check it out if you can

    Thank you very much again!

    I meant .. On the back! 😀 Sorry!

    Make it:
    <?php wp_list_pages('exclude=XX,XX&title_li='); ?>

    That fixed it!

    Thank you very much!! Really… Thank you!!


    One more thing:

    How can I have them ordered by menu order and still excluding?

    Its working now, but the order of the pages on the header aint right (I want it to be ordered by the menu number)

    Sorry and thank you!!

    You never visited the Codex page I linked, LOL…
    then go into the Manage Pages > Edit and in the Page Options (below the text input area) define the order numbers.

    I have. I promisse. What I dont know, is how to combine both!

    Excluding and Ordering by Menu Order.

    It’s always the same, using &

    LOL. Done … But trust me …

    It may sound easy to you … But it aint! 😛 😛

    Thank you very much! Everything working perfectly now!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Hiding Pages’ is closed to new replies.