WordPress.org

Support

Support » Themes and Templates » [Resolved] Hiding page title on twentyeleven theme.

[Resolved] Hiding page title on twentyeleven theme.

  • petematheson
    Member

    @petematheson

    I’m creating a new site (www.performanceacademyltd.com) which I’m creating custom pages for.
    So far I’ve edited the header and footer files, created a new page (/home) and pasted my content onto it.

    However, I still have the Page Title showing up.

    I’ve done it once before on my own wordpress blog but can’t remember how – and I remember it took me a while to search to find an answer!

    Can anyone point me to the quick fix to remove or hide the Title from this page?

    Thanks

Viewing 15 replies - 1 through 15 (of 36 total)
  • esmi
    Forum Moderator

    @esmi

    Do not edit the Twenty Eleven theme. It is the default WordPress 3.2 theme and having access to an unedited version of the theme is vital when dealing with a range of site issues. Create a child theme for your changes. Once your child theme is active, we should be able to help with the customisation.

    petematheson
    Member

    @petematheson

    Ah sorry – I have taken a copy of the twenty eleven theme then edited the CSS and changed the placeholder picture.

    Should I still follow that guide as above?

    esmi
    Forum Moderator

    @esmi

    Is the modified theme running as a completely new theme with a different name? If so, we’d need to be able to see the site – not a holding page.

    petematheson
    Member

    @petematheson

    Yes it is.

    Sorry, my mistake
    http://www.performanceacademyltd.com/blog

    That would help!

    esmi
    Forum Moderator

    @esmi

    You site doesn’t appear to be using any of the CSS from the theme!

    petematheson
    Member

    @petematheson

    Correct

    So – how do I get rid of the title?

    🙂

    esmi
    Forum Moderator

    @esmi

    The simplest option would be to hide it via CSS.

    petematheson
    Member

    @petematheson

    Do you know to which item I need to apply the display:none; style to?

    I’ve tried it on a couple but they don’t seem to hide it

    esmi
    Forum Moderator

    @esmi

    Try using Firefox with the Firebug add-on for this kind of work.
    http://getfirebug.com/

    petematheson
    Member

    @petematheson

    Confused here, I’ve done that with Firebug and set the following in my css

    . entry-title h1 { display:none;}
    . entry-header h1 { display:none; }

    Yet it’s still showing the Title?

    esmi
    Forum Moderator

    @esmi

    On what page of the site are these titles?

    petematheson
    Member

    @petematheson

    On every page that I create.

    It’s on my home page (www.performanceacademyltd.com/blog)

    See where it says ‘HOME’ at the top below the logo.

    esmi
    Forum Moderator

    @esmi

    Well, if you added that CSS to your site’s style.css (not the theme’s style.css file), it’s not being loaded – which explains why the title is still visible.

    petematheson
    Member

    @petematheson

    Ah, silly little thing.

    there was a space in my . entry-title h1 css tags.

    changed to
    .entry-title h1 { display:none;}
    .entry-header h1 { display:none; }

    Now all working

    Thank you !

    William
    Member

    @wisemasterchief

    1. Download and install companion plugin
    2. in your dashboard, go to appearance -> companion
    3. this will bring up CSS Override Editor
    4. enter the following code and save:

    .entry-title
    {
    display: none !important;
    }

    WORKS FOR ME .. I would rather use this process … updates will not overwrite my custom CSS. ~peace

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘[Resolved] Hiding page title on twentyeleven theme.’ is closed to new replies.