WordPress.org

Support

Support » Themes and Templates » Hide/Remove remove leave a comment link wordpress

Hide/Remove remove leave a comment link wordpress

  • I have the ‘leave a comment link’ on a post but can;t seem to find the code to uncomment it or remove it?

    Any ideas?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Sorry that’s for the Twenty Ten theme

    I am trying to do the same thing.

    im trying to do this also. i too am running twenty ten theme. someone out there has gotta know how to remove the Leave a Comment link???

    The only way I can see at the moment is to display none the comment

    Add this to your stylesheet

    .comments-link {
    display: none;

    }

    that will work for now. thanks bro! hopefully someone can tell us how to get rid of it all together.

    esmi

    @esmi

    Forum Moderator

    loop.php: <?php comments_popup_link( __( 'Leave a comment', 'twentyten' ), __( '1 Comment', 'twentyten' ), __( '% Comments', 'twentyten' ) ); ?>

    that code appears 3 times in my loop.php and I removed all 3 and still the link shows up. the stylesheet code that silverbadger gave me got rid of the link itself but there is still a “|” next to where the Leave a Comment link usually appears.

    I tried deleting the stuff esmi said and it still shows up for me to.

    someones gotta know the answer to this problem. it seems so trivial. im surprised that removing the link is not a simple task.

    esmi

    @esmi

    Forum Moderator

    Remember to press CTRL and F5 simultaneously when viewing an updated page/site. Or try emptying your browser cache. This should ensure that your web browser fetches a fresh copy of the page rather than serving up an out-dated copy from your own cache.

    Also disable/deactivate any caching plugin(s).

    silverbadger –

    PLEASE PLEASE tell me EXACTLY where to insert this code
    are you doing it in the WordPress online editor
    admin/appearance/editor
    or downloading files from your web server

    where do I go…what file is it?

    .comments-link {
    display: none;

    }

    I’ve been trying to get an answer to this question for over a week. and there’s an inordinate amount of confusion and misinformation being posted about what should be a a very simple issue IMO.

    it should be part of the functionality of this software (and well documented)

    I suppose comments are an important part of blogging, generally, but to treat them as if they were essential is incorrect.

    silverbadger –

    i found it myself

    i did it online at

    admin/appearance/editor and then I clicked the link on the right for Stylesheet (style.css)
    and inserted that code in the very top of the “comments” section of that page…like so

    /* =Comments
    ————————————————————– */

    #comments .navigation {
    padding: 0 0 18px 0;
    }
    h3#comments-title,
    h3#reply-title {
    color: #fff;
    font-weight: bold;
    font-size: 20px;
    margin-bottom: 0;
    }
    h3#comments-title {
    padding: 24px 0;
    }
    .comments-link {
    display: none;

    hopefully this will help others with the same issue

    thank you so much ;o;o;o

    ryan093

    @ryan093

    open up the file wp-content/themes/theme-name/index.php you’ll see it in there.

    hi! i have the same problem. but i can’t figure out what to do???? can someone give me instructions? do i go into the stylesheet and remove the whole section on comments and replace it with something else? sorry, i’m completely clueless when it comes to this. this is my first “website” (alkray.com) and i’m no computer whizz….

    Go to the WP EDITOR and click on the link on the right side of the page that says page.php and delete the line of code in that page that says: get comment true

    Sorry I don’t have the exact code snippet because i just deleted it from my page and then my conscience realized i should share on here what worked for me…

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Hide/Remove remove leave a comment link wordpress’ is closed to new replies.
Skip to toolbar