Support » Plugin: WP Mail SMTP by WPForms » Hide the password

  • Resolved taisa1984

    (@taisa1984)


    Hi!

    I have the same issue stated here: https://wordpress.org/support/topic/hide-password-in-wp-config-blocks-sending/

    I am configuring the emails, and with the password on the field it works, and when I add it to the wp-config.php file it doesn’t work. I am trying with the plugin Test email.

    Here are the info details (I edited the domain) when I try to send the test email with the wp-config option:

    Versions:
    WordPress: 5.4
    WordPress MS: No
    PHP: 7.3.17
    WP Mail SMTP: 1.9.0

    Params:
    Mailer: smtp
    Constants: Yes
    ErrorInfo: SMTP Error: Could not authenticate.
    Host: send.one.com
    Port: 465
    SMTPSecure: ssl
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: OpenSSL 1.1.1 11 Sep 2018
    SMTP Debug:
    2020-04-18 16:13:58 Connection: opening to ssl://send.one.com:465, timeout=300, options=array ()

    2020-04-18 16:13:58 Connection: opened

    2020-04-18 16:13:58 SERVER -> CLIENT: 220 mailout1.pub.mailoutpod1-cph3.one.com ESMTP

    2020-04-18 16:13:58 CLIENT -> SERVER: EHLO (Mi dominio).com

    2020-04-18 16:13:58 SERVER -> CLIENT: 250-mailout1.pub.mailoutpod1-cph3.one.com250-PIPELINING250-SIZE 104857600250-AUTH LOGIN PLAIN250-ENHANCEDSTATUSCODES250 8BITMIME

    2020-04-18 16:13:58 CLIENT -> SERVER: AUTH LOGIN

    2020-04-18 16:13:58 SERVER -> CLIENT: 334 VXNlcm5hbWU6

    2020-04-18 16:13:58 CLIENT -> SERVER: YWNhZGVtaWFAZW1wcmVuZGVkb3Jhc3ltYWRyZXMuY29t

    2020-04-18 16:13:58 SERVER -> CLIENT: 334 UGFzc3dvcmQ6

    2020-04-18 16:13:58 CLIENT -> SERVER: KE1tPl9tZ19pbXhfZ2dReGU3

    2020-04-18 16:13:58 SERVER -> CLIENT: 535 5.7.8 Authentication failed

    2020-04-18 16:13:58 SMTP ERROR: Password command failed: 535 5.7.8 Authentication failed

    SMTP Error: Could not authenticate.

    2020-04-18 16:13:58 CLIENT -> SERVER: QUIT

    2020-04-18 16:13:58 SERVER -> CLIENT:

    2020-04-18 16:13:58 SMTP ERROR: QUIT command failed:

    2020-04-18 16:13:58 Connection: closed

    SMTP Error: Could not authenticate.

    • This topic was modified 10 months, 1 week ago by taisa1984.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Gregor Capuder

    (@capuderg)

    Hi,

    I’ve tested setting the SMTP password via constants, by adding this to my wp-config.php file:

    
    define( 'WPMS_ON', true );
    define( 'WPMS_SMTP_PASS', 'your_password' );
    

    changing the your_password to my actual SMTP password (keeping the single quotes around my SMTP password). And the email was still sent just OK. I’ve tested with two different SMTP accounts and they both worked as expected.

    In order to debug this on our end could you please let me know which constants you added to your wp-config.php file (just the constant names, not the actual values).

    Thank you!

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @taisa1984 – We haven’t heard from you in about a week, so I’m going to go ahead and mark this ticket resolved. If you still have questions, though, please feel welcome to continue the conversation.

    Thread Starter taisa1984

    (@taisa1984)

    I still had no time to check on this, I will as soon as I can.

    Thread Starter taisa1984

    (@taisa1984)

    Ok, Now I could take a look at this. Sorry for taking so much time.

    I think I found the problem. I had made it as told on the info and the previous message, but now when I came back and took a look noticed my password had a bracket ( on it. I changed it with symbols but no brackets and now it works just fine.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Hide the password’ is closed to new replies.