Support » Theme: Spacious » Hide Sidebar Not Working

  • Resolved iidnew

    (@iidnew)


    I am looking to hide the right-hand sidebar on the Shop page of this website:
    http://planetbotanix.com/shop/
    The sidebar contains a custom menu (‘Practitioners’ – menu id 146).

    I have already selected the “No Sidebar Full Width” page layout option in the page editor for the Shop page (page id 11), however the sidebar is still being displayed below the WooCommerce content, above the footer.

    I would really appreciate it if someone could help- I have the Custom CSS plugin installed, so a CSS solution would be preferred.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Justin P

    (@justinpartain)

    Have you tried any custom css so far?

    Anonymous User 12851872

    (@anonymized-12851872)

    Hi,
    This is the forum for spacious free, you use spacious Pro, you have to create a ticket there https://themegrill.com/support-ticket/
    But did you do what is indicated in the demo?
    https://demo.themegrill.com/spacious-pro/no-sidebar-content-centered/

    – This page layout is set to No Sidebar Content Centered. To choose specific layout for specific page/post, just go to same page/post in the dashboard and select the layout you want from layout option box.

    or No Sidebar Full Width
    – This page has its layout set to No Sidebar Full Width. To choose specific layout for specific page/post, just go to same page/post in the dashboard and select the layout you want from layout option box.

    Try using the below CSS code –

    #secondary{
    display: none;
    }

    Thread Starter iidnew

    (@iidnew)

    @justinpartain

    I have tried some CSS, yes, however none of it worked. I am not trained in CSS, so they were all Frankenstein codes of other suggestions I found online and probably incorrect to being with.

    @noaneo

    Thank you for the information. Yes, I have tried changing the page layout to both No Sidebar Content Centered and No Sidebar Full Width. Changing the page layout does not seem to make a difference at all on this page. I will make a ticket as recommended.

    @mayankmajeji

    Thank you, something like that is exactly what I am looking for! I need to specify that the sidebar is to be hidden only on this one page (page id 11), how do I write that into the Custom CSS?

    Anonymous User 12851872

    (@anonymized-12851872)

    Hi,
    Try this code in Customize > Custom CSS

    .page-id-11 #secondary{
    display: none;
    }
    Thread Starter iidnew

    (@iidnew)

    @wolfneo thank you, that’s exactly what I needed – works perfectly now.

    Really appreciate your help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Hide Sidebar Not Working’ is closed to new replies.