WordPress.org

Forums

Viper's Video Quicktags
Hide related videos on You Tube (9 posts)

  1. sachacriado
    Member
    Posted 2 years ago #

    HI,

    Related videos on You Tube appear at the end, although the box is off. Please see example http://www.locutorsachacriado.com/blog
    on 3rd slide.

    Thanks

    http://wordpress.org/extend/plugins/vipers-video-quicktags/

  2. desertkristin
    Member
    Posted 2 years ago #

    I am experiencing the same issue. I have the checkbox unchecked in the settings panel and I am sure I saved but still see related videos on all embeds throughout the site.

    A solution would be much appreciated!
    Thanks!
    **Kristin**

  3. Zarf
    Member
    Posted 1 year ago #

    Same here. Need a solution!

  4. peteratomic
    Member
    Posted 1 year ago #

    Same problem for me!

  5. holmpage
    Member
    Posted 1 year ago #

    Me too. I finally just used the YouTube embed code, as it was for just one video on the whole site.

  6. Pixelpillow
    Member
    Posted 1 year ago #

    Found a (dirty) solution. Go to "vipers-video-quicktags.php" and edit line 2992.

    Change "&rel=0" to "?rel=0".

    Worked for me!

  7. IAMABANANA
    Member
    Posted 1 year ago #

    Clean (non-tweaking plugin source) solution:

    Make sure that youtube videos are set to not play related videos in your Viper plugin settings, then go to the video on youtube. Click the "Share" tab, then click the "Embed" option. Check "Use old embed code". Copy everything from the value parameter after "//www.youtube.com/v" and paste in between the youtube shortcode tags. Then change the & a m p ; to &.

    Should look like this:
    [youtube]/aBcDeFg123?hl=en_US&version=3[/youtube]

  8. rafaelmoraesdefreitas
    Member
    Posted 1 year ago #

    I fixed this problem doing that on the vipers-video-quicktags.php

    line 2988:

    $url = 'http://www.youtube.com/' . $embedpath . $color1 . $color2 . $border . '&rel=' . $rel . '&fs=' . $fs . '&showsearch=' . $showsearch . '&showinfo=' . $showinfo . $autoplay . $loop . $hd;
    		$url = (strpos($url, '?') === false) ? preg_replace('/&/', '?', $url, 1) : $url;
    $this->swfobjects[$objectid] = array(
    			'width' => $atts['width'],
    			'height' => $atts['height'],
    			'url' => $url,
    		);

    line 3851 (more or less):
    $content .= ' swfobject.embedSWF("' . $this->wpuntexturize(esc_url($embed['url'])) . '", "' . esc_js( $objectid ) . '", "' . esc_attr( absint( $embed['width'] ) ) . '", "' . esc_attr( absint( $embed['height'] ) ) . '", "10", vvqexpressinstall, ';

  9. dloxton
    Member
    Posted 1 year ago #

    Thank you @rafaelmoraesdefreitas - that worked for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Viper's Video Quicktags
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic