Support » Theme: GeneratePress » Hide page title

  • Hello,

    I’ve been able to hide the page titles but on search results the titles are missing.

    Is there any way I can get the titles to be shown on search results only.

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi there,

    How have you hidden the Title ?

    Thread Starter ahearne

    (@ahearne)

    Hi,

    Thanks for your reply, through GeneratePress Additional CSS I put

    h1.site-title {
    display: none;
    }
    h2.site-description {
    display: none;
    }

    .entry-title {
    display: none;
    }

    I’ve tried this too but still will not show the titles in search results.

    .search-results article.page .entry-header h1.entry-title {
    display: block;

    Change this:

    h1.site-title {
      display: none;
    }

    to:

    body:not(.search-results) h1.site-title {
      display: none;
    }
    Thread Starter ahearne

    (@ahearne)

    Hi,

    Thanks I tried it but the titles still not show in the search results which is what I want but not on the main page, will see if have another plugin forgot to disable but here you will see how it is at moment.

    http://doctorwhoworlduk.com/?s=jodie%20whittaker

    Thanks

    Guido

    (@guido07111975)

    Hi,

    Why are you hiding site title and description (tagline) via CSS while you can do the same via the theme settings in the Customizer > Site Identity? And you can disable page title per page in the page editor.

    Guido

    Thread Starter ahearne

    (@ahearne)

    Hi Guido,

    Forgot about Site Identity. I don’t think that it goes well with my website as it’s a website and not a blog thought try and keep it so it was not so big.

    Oh well, thanks

    Guido

    (@guido07111975)

    Hi,

    If you still want to hide all page titles with custom CSS, try this:

    
    h1.entry-title {display:none;}
    

    The page title of search results page (Search results for) has another CSS class, so it will stay visible.

    Guido

    • This reply was modified 1 month, 3 weeks ago by Guido. Reason: Have updated my reply
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.