WordPress.org

Support

Support » How-To and Troubleshooting » Hide page title

Hide page title

  • Hi,

    So I have a blog and I am using the Mystique theme. The problem is all my pages are in the menu bar which is great but then at the top of each page it puts the name of the page. It looks tacky and I definitely don’t need to be told what page I am on twice soo closely to each other.

    If anybody knows how to hide the page title that would be great!

    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Oh I wanna know too!

    Moderator Michael

    @alchymyth

    Forum Moderator

    there should be a setting in ‘admin’ ‘appearance’ ‘mystique (?)’

    no thats not an option for my theme.

    I found it in the code and deleted:

    <?php /* If this is a category archive */ if (is_category()) { ?>
    		<h2 class="pagetitle">Archive for the ‘<?php single_cat_title(); ?>’ Category</h2>

    but then the page doesnt work…

    Moderator Michael

    @alchymyth

    Forum Moderator

    @sonotaverage:

    Oh I wanna know too!

    you came here, hijacking someone else’s thread – pretending to have the same problem. and you don’t even use the same theme. 🙁

    open a new thread and describe more in detail what you want help with:
    post the name of your theme, and a link to your site.

    There isn’t a

    there should be a setting in ‘admin’ ‘appearance’ ‘mystique (?)’

    in my settings.

    Sorry

    Moderator Michael

    @alchymyth

    Forum Moderator

    you are right – i was fooled by the ‘if’ in the page title code, which uses a custom field to hide the title of individual pages.

    make a backup copy of your theme files before editing

    edit page.php and fing:

    <?php if (!get_post_meta($post->ID, 'hide_title', true) && !is_page_template('featured-content.php')): ?><h1 class="title"><?php the_title(); ?></h1><?php endif; ?>

    remove this all (no more, no less) to get rid of the titles at the top of the page.

    I figured why make a topic if there already is one… but okay, I’ll make my own. BTW I’m pretty positive me and him have the exact same problem. None the less.

    Incase you didn’t figure this out…

    When you create a page, in the custom fields section. Name…add “hide_title” (no quotes). Value…”true” (no quotes) Do this for every page you don’t want the title to show on.

    Thanks! That worked for me and it was easier than finding another plug in to do it or editing the code.

    I tried this and its not working:(
    please help me im pulling my hair out over this at this stage!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Hide page title’ is closed to new replies.